We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 24629
    • 370 Posts
    Hi all,

    i just tried to upgrade to 2.0.7. I uploaded all files to the server. and navigate to the /setup folder.
    there i see a truckload of errors.

    [tt]Warning: touch() [function.touch]: Utime failed: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_template.php on line 254

    Warning: rename(/tmp/wrtvf1yH1,/home/ID0010/domains/xxxxx.xxx/public_html/core/cache/setup/smarty/e7e557dde553e07ba613527bee17814be79a5480.file.header.tpl.php) [function.rename]: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 42

    Warning: chmod() [function.chmod]: Operation not permitted in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 44

    Warning: touch() [function.touch]: Utime failed: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_template.php on line 254

    Warning: rename(/tmp/wrtsReaeb,/home/ID0010/domains/xxxxx.xxx/public_html/core/cache/setup/smarty/e7e557dde553e07ba613527bee17814be79a5480.file.header.tpl.php) [function.rename]: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 42

    Warning: chmod() [function.chmod]: Operation not permitted in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 44

    Warning: rename(/tmp/wrtxj7lYk,/home/ID0010/domains/xxxxx.xxx/public_html/core/cache/setup/smarty/abcc63de34c538424d15b1c83d91b5d138e4d6b4.file.language.tpl.php) [function.rename]: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 42

    Warning: chmod() [function.chmod]: No such file or directory in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 44

    Warning: touch() [function.touch]: Utime failed: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_template.php on line 254

    Warning: rename(/tmp/wrt65SLOu,/home/ID0010/domains/xxxxx.xxx/public_html/core/cache/setup/smarty/ca8a32a33ef11067f68163552da8cd455d5fe1fb.file.footer.tpl.php) [function.rename]: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 42

    Warning: chmod() [function.chmod]: Operation not permitted in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 44

    Warning: touch() [function.touch]: Utime failed: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_template.php on line 254

    Warning: rename(/tmp/wrtDK3fLE,/home/ID0010/domains/xxxxx.xxx/public_html/core/cache/setup/smarty/ca8a32a33ef11067f68163552da8cd455d5fe1fb.file.footer.tpl.php) [function.rename]: Permission denied in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 42

    Warning: chmod() [function.chmod]: Operation not permitted in /home/ID0010/domains/xxxxx.xxx/public_html/core/model/smarty/sysplugins/smarty_internal_write_file.php on line 44[/tt]

    Anyone any idea what i did wrong?
    Ralph
      • 21838
      • 284 Posts
      Seems to be a permission problem. Try to delete these files manually and reupload the new ones. There shouldn’t be any problems with these files.
        MODX Free Template Base: MODX-Boilerplate | my blog (lots of MODX stuff) | my gitHub (translations) | MODX User Groups Germany (Facebook)
        • 24629
        • 370 Posts
        Hi,

        Ok i figured out what happend with te first part of the upgrade. The owner of a lot of docs change to ’Apache’ insteadof ’me’.
        Now i changd them all back to me and change the permissions to 777 the setup worked.

        BUT... now the manager does not work properly anymore!
        I can see the document tree and the navigation. I can edit a page but the rest is blank.
        When i try to change the system settings i get a blank page same for all the other pages from the top navigation...
        Please help.... ralph
          • 21838
          • 284 Posts
          DID you empty your cache?
          Delete all contents of core/cache and the one of your browser.
            MODX Free Template Base: MODX-Boilerplate | my blog (lots of MODX stuff) | my gitHub (translations) | MODX User Groups Germany (Facebook)
            • 24629
            • 370 Posts
            Hi,

            Yep, i emptied the cache of both then went to /setup. the setup page showed up just fine except that there was 15min. timeout warning stating i had to restart the setup.
            Which did not work at all. The cure for that was to empty the core/cache folder.
            So i’m sure that folder was empty.
            After that the setup went fine (all green OK’s) it cleaned up the setup folder and behaved like a good boy.
            Then i logged in on the manager to discover parts of it stay blank (i dont see any errors).

            i’m totaly at a loss here.

            Tnx,
            Ralph
              • 21838
              • 284 Posts
              Do you have Firebug for Firefox? Can you please look if there are some errors displayed? Especially in JS?
                MODX Free Template Base: MODX-Boilerplate | my blog (lots of MODX stuff) | my gitHub (translations) | MODX User Groups Germany (Facebook)
                • 24629
                • 370 Posts
                Hi Apart from a shitload of CSS errors (as seen in Firebug) there is one JS error

                Error: b is null
                Source File: http://www.xxxxxx.xx/manager/assets/ext3/ext-all.js
                Line: 7


                Ralph
                  • 36502 ☆ A M B ☆
                  • 491 Posts
                  Quote from: rdaneeel at Jan 17, 2011, 01:57 AM

                  Ok i figured out what happend with te first part of the upgrade. The owner of a lot of docs change to ’Apache’ insteadof ’me’.
                  Now i changd them all back to me and change the permissions to 777 the setup worked.

                  Hi, have you checked files and folders permissions after upgrade?




                    TilliLab | MODX Ambassador
                    website
                    • 24629
                    • 370 Posts
                    @pandro: no why?
                    ralph
                      • 36502 ☆ A M B ☆
                      • 491 Posts
                      Actually I had some similar problems with the upgrade to a previuos revolution release:

                      -I migrated my website to a new server, everything was working fine.
                      -After sometimes, I had to upgrade MODx and I found some problems with the process (if I remember correctly a blank screen during the process).
                      - I checked and changed the folders permission: the setup-upgrade process worked fine, but as soon as I logged into the manager I found out some blank screen again...Not everything, but some section of the manager.
                      - so I changed some other folder permission, I don’t remember exactly which folder caused the problem (may be controllers, or connectors, but really I don’t remember).

                      Anyway after setting some folders to the most un-secure 777 I solved the problem...

                      After that my system administrator "cleaned" folder permissions setting ownership and writing permission correctly, at least I hope so smiley


                        TilliLab | MODX Ambassador
                        website