I was working on my site yesterday and then suddenly, I started to get 500 Internal server errors when i’m trying to edit a chunk.
Right now, as soon as I click on a chunk in the elements tree to edit it, i got this error. I doesn’t matter which chunk i try to edit. I can edit all other element types without problems.
I also gets this error when i’m trying to submit the Login.Register form in the frontend.
I tried to reinstall revo 2.0.6-pl2 as a way to solve my problems and then got a 500 error during the installation (between the confirmation of prerequisites and the installation report). As this was a reinstall, my site still works though.
I can’t see what I have done to cause this. Can I do anything in the manager that will cause this type of problem? Is it a fault in modx or is it a fault that my service provider is responsible for?
The error log in the manager is empty.
I’m using revo 2.0.6-pl2 traditional with mysql 5.0.51a-24+lenny5-log and php 5.3.5.
I would first try deleting all the files in the core/cache directory, clearing the browser cache/cookies and doing another upgrade install (you did do one, right?).
If that doesn’t do it, the fact that the front-end is ok and you can do other things in the Manager suggests that either one or more files was corrupted in the file transfer, or the file transfer failed to overwrite some old core files. That’s not uncommon if you used FTP to transfer the files.
Thank you!
I removed all files in core/cache.
Then cleared my browser cache and last but not least upgraded to revo 2.0.7-pl.
This solved all my problems.
The key thing seems to be that i manually cleared the cache. Before i tried the first upgrade install, i cleared the cache from the manager but i then got a 500 error during the installation.