*** APOLOGIES IN ADVANCE IF YOU HAVE READ THIS BUT I CAN’T FIND A WAY TO DELETE ORIGINAL POST ***
Hi
I have created and been running my clients website for them and yesterday I made some text changes to a few pages and when I refreshed the pages the screen was blank but within the CMS I could only see the page structure from the Resources tab but no content when I clicked on a resource.
I had to speak to a friend (who doesn’t know MODx but knows about databases etc) and through reading a post on here:
http://modxcms.com/forums/index.php?topic=57192.0 he was able to clear the sites cache and everything was back up including the resources content area.
Now this morning I made another text amend and now not only do all the pages have blank screens but also I am not able to access the CMS Manager.
I have been using MODx Revolution 2.0.4-pl2 if that is of any use/help?
In the error_log message it seems to be creating a loop of this:
[Wed Jan 12 09:57:18 2011] [error] [client 88.211.31.58] FastCGI: server "/var/www/fcgi/php-cgi" stderr: PHP Warning: array_merge() [<a href=’function.array-merge’>function.array-merge</a>]: Argument #2 is not an array in /home/linweb01/m/mayvin.co.uk-9668733/user/htdocs/core/model/modx/modx.class.php on line 2769
[Wed Jan 12 09:57:18 2011] [error] [client 88.211.31.58] FastCGI: server "/var/www/fcgi/php-cgi" stderr: PHP Fatal error: Class ’modContext_’ not found in /home/linweb01/m/mayvin.co.uk-9668733/user/htdocs/core/xpdo/xpdo.class.php on line 550
Is there anything I can do? I have already sent an email to the hosting company to ask if they have changed anything and still waiting to hear back from them.
I am a front end developer so not quite sure where to start to try and rectify the issue.
The database has been backed up, and on the live server, everything seems intact - database that is. From the thread:
http://modxcms.com/forums/index.php?topic=57192.0 The guy resolved his issue by reinstalling the CMS but can this be avoided? OR is this the overall best solution.
Thanks in advance