We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28508
    • 73 Posts
    Hi guys,

    after updating from 2.0.4 to 2.0.5 (advanced) I’ve new icons and the new form-customization, but I do NOT have the improved access controls, it’s simply still the old system.

    I recieved the following errors:

    [2010-12-19 15:21:42] (ERROR @ /setup/index.php) Could not copy /path/web/core/packages/core/modContext/b4e708643f26093c4fa9f58a3441c8a6/0/ to /path/web/index.php 
    [2010-12-19 15:21:42] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (/path/web/core/packages/core/modContext/b4e708643f26093c4fa9f58a3441c8a6.resolve.core.resolver)
    [2010-12-19 15:21:42] (ERROR @ /setup/index.php) Could not resolve vehicle for object of class modContext; criteria: web
    


    Actually I’m not sure if my old access-rules still work properly, I created a new context and had problems to create a resource there (it was created in the standard web-context, had to change context key in the database manually to see it), but maybe I didn’t configure the rules right. But the access-control-system is definetely the old one.

    Does anyone have a hint for me how to fix that up?

    Thank you very much,

    stetus

    Environment:

    MODx Revolution 2.0.5-pl (advanced)
    PHP Version 5.3.2-1ubuntu4.5
    Database: MYSQL 5.1.41-3ubuntu12.7
      • 28215
      • 4,149 Posts
      Sounds like you didn’t have the right file permissions set when you upgraded, and the files didn’t get copied.

      I’d run setup again, and make sure the options are checked on the options page. Make sure the appropriate directories are writable as well.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 28508
        • 73 Posts
        Hi Shaun,

        thanks for your answer.
        Don’t know what went wront, 2.0.6 fixed it.

        Thank you for your support!