We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    Quote from: Letti at Jan 19, 2011, 04:49 PM

    Ok, we finally recognized that cache_db is set in an original MODx-installation by default to "no". We have no idea why this was set (or why we set this) to yes in our settings.

    But after all we are very happy that this problem is probably solved right now and we can concentrate on other important challenges again. Thanks to all who gave us all the time so many hints and help!
    It works fine in my sites with this set to yes, so there is obviously a problem somewhere that needs to be identified and resolved, either in some component implemented on your site, or in the core. Let me know if you can diagnose the error in more detail and report where/why/when the problem is occurring.

    Quote from: backdoc at Jan 28, 2011, 05:51 PM

    Just in case someone else runs into this, I am running a Mac. I did two things to correct it.

    First, I created an /etc/my.cnf file per Apple instructions and added these two lines:

    1 [mysqld]
    2 socket=/tmp/mysql.sock

    Also, I noticed that I was overlooking the two of these lines in php.ini. I only knew to change one of them.

    pdo_mysql.default_socket = /tmp/mysql.sock
    mysql.default_socket = /tmp/mysql.sock
    mysqli.default_socket = /tmp/mysql.sock

    Searching a phpinfo() page helped track these down.
    FWIW, this is detailed here.
      • 17016
      • 138 Posts
      It works fine in my sites with this set to yes, so there is obviously a problem somewhere that needs to be identified and resolved, either in some component implemented on your site, or in the core. Let me know if you can diagnose the error in more detail and report where/why/when the problem is occurring.

      Hi OpenGeek,
      do you have any idea what could be the reason for not working this feature in our setting or how we could find it out? Maybe a not very good configurated server?

      As described above the errors appear when opening different (so far uncashed) pages at the same time. If the sites are once cached the problem will not appear anymore...