-
☆ A M B ☆
- 3,112 Posts
The upgrading was finished though.
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) No foreign key definition for parentClass: modAccessPolicy using relation alias: Permissions
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not install related objects for vehicle object of class modAccessPolicy; criteria: Array
(
[name] => Resource
)
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) No foreign key definition for parentClass: modAccessPolicy using relation alias: Permissions
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not install related objects for vehicle object of class modAccessPolicy; criteria: Array
(
[name] => Administrator
)
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) No foreign key definition for parentClass: modAccessPolicy using relation alias: Permissions
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not install related objects for vehicle object of class modAccessPolicy; criteria: Array
(
[name] => Load Only
)
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) No foreign key definition for parentClass: modAccessPolicy using relation alias: Permissions
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not install related objects for vehicle object of class modAccessPolicy; criteria: Array
(
[name] => Load, List and View
)
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) No foreign key definition for parentClass: modAccessPolicy using relation alias: Permissions
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not install related objects for vehicle object of class modAccessPolicy; criteria: Array
(
[name] => Element
)
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not find Administrator Access Policy Template
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not find Element Access Policy Template
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not find Object Access Policy Template
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not find Object Access Policy Template
[2010-12-10 01:53:37] (ERROR @ /[mywebsite.com]/www/setup/index.php) Could not find Resource Access Policy Template
FYI,
The web-root is /[mywebsite.com]/www/
The core-path is /[mywebsite.com]/core/
Testing continues...
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
-
☆ A M B ☆
- 3,112 Posts
Some icons become missing.
Apache’s error log:
[Fri Dec 10 02:03:51 2010] [error] [client 127.0.0.1] File does not exist: D:/localhost/[mywebsite.com]/www/[newmanagername]/templates/default/images/restyle/icons/page_white_copy.png, referer: http://localhost/[mywebsite.com]/www/[newmanagername]/index.php?a=60
[Fri Dec 10 02:03:51 2010] [error] [client 127.0.0.1] File does not exist: D:/localhost/[mywebsite.com]/www/[newmanagername]/templates/default/images/restyle/icons/page_white_gear.png, referer: http://localhost/[mywebsite.com]/www/[newmanagername]/index.php?a=60
[Fri Dec 10 02:03:51 2010] [error] [client 127.0.0.1] File does not exist: D:/localhost/[mywebsite.com]/www/[newmanagername]/templates/default/images/restyle/icons/page_white_link.png, referer: http://localhost/[mywebsite.com]/www/[newmanagername]/index.php?a=60
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
-
☆ A M B ☆
- 3,112 Posts
Oh my,
I can not continue using this upgrade.
Since then, I can not create a new resource.
It goes to a blank screen on that action.
This is the Apache’s error log.
[Mon Dec 13 16:57:23 2010] [error] [client 127.0.0.1] PHP Fatal error: Cannot pass parameter 1 by reference in D:\\localhost\\[mywebsite.com]\\www\\[mymanager]\\controllers\\default\\resource\\create.php on line 186, referer: http://localhost/[mywebsite.com]/www/[mymanager]/index.php?a=55
This is what live site said (I tried to ignore all above errors)
Fatal error: Cannot pass parameter 1 by reference in /home/[username]/public_html/[mymanager]/controllers/default/resource/create.php on line 186
Rico
Genius is one percent inspiration and ninety-nine percent perspiration.
Thomas A. Edison
MODx is great, but knowing how to use it well makes it perfect!
www.virtudraft.com
Security, security, security! |
Indonesian MODx Forum |
MODx Revo's cheatsheets |
MODx Evo's cheatsheets
Author of
Easy 2 Gallery 1.4.x,
PHPTidy,
spieFeed,
FileDownload R,
Upload To Users CMP,
Inherit Template TV,
LexRating,
ExerPlan,
Lingua,
virtuNewsletter,
Grid Class Key,
SmartTag,
prevNext
Maintainter/contributor of
Babel
Because it's hard to follow all topics on the forum, PING ME ON TWITTER
@_goldsky if you need my help.
Quote from: endif at Dec 28, 2010, 02:46 AM
Had the same problem after upgrading an advanced install from 2.0.4 to 2.0.6
Solution was to replace the files in the /manager folder with files from a fresh download of modx revo 2.0.6 (the Traditional download).
[edit]
there’s a bugreport here: http://bugs.modx.com/issues/3074 and an issue here: http://bugs.modx.com/issues/3167
Would it be correct if I ’update’ this bugreport with this info or is this something an admin/developer would need to do?
Go ahead. It can’t hurt.
Although in both cases, it might have just been that a file or two was corrupted during the file transfer. There are literally thousands of files and it happens more often than you might think.
I think the cause of the issue was that, although my manager directory was writable, the files inside that directory weren’t.
The installer just checked the directory itself and then failed to over-write the required files.
Absolutely. Its more that I failed to make the files writabe than the installer not checking everything.
It’s an "Advanced" installation, so advanced thinking can be assumed.
Some sort of notification would be nice, though.