We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19629
    • 21 Posts
    Hi there,

    I am running Modx Revo 2,0 on a Windows server IIS7 I have IIS Mod_Rewrite installed.

    Every now and again at lease once a day the application pool will need restarting as the site crashes and all I get is a 500 error message.

    My host tell me its a code error so I was wandering if anybody has had the same problem and found a solution for it.

    Regards

      • 22303 MODX Staff
      • 10,725 Posts
      Quote from: Minikoopa at Dec 06, 2010, 05:31 AM

      Hi there,

      I am running Modx Revo 2,0 on a Windows server IIS7 I have IIS Mod_Rewrite installed.

      Every now and again at lease once a day the application pool will need restarting as the site crashes and all I get is a 500 error message.

      My host tell me its a code error so I was wandering if anybody has had the same problem and found a solution for it.
      If your host is blaming the code, they need to specify what code is causing this 500 error. This generally happens because of a problem with configuration between the web server and PHP, not because of PHP code errors, which should never trigger a 500 error. This indicates the PHP CGI process itself is crashing.
        • 19629
        • 21 Posts
        You are correct. I asked my host for an error so that I could post it on here. They tell me there is not one.

        We have changed from ISAPI to fast CGI to see if this helps. I have been running for 3-4 hours with no problems so hopefully that has cracked it.
          • 22303 MODX Staff
          • 10,725 Posts
          Quote from: Minikoopa at Dec 06, 2010, 10:18 AM

          You are correct. I asked my host for an error so that I could post it on here. They tell me there is not one.

          We have changed from ISAPI to fast CGI to see if this helps. I have been running for 3-4 hours with no problems so hopefully that has cracked it.
          You should absolutely be using FastCGI for PHP on IIS 7.5.
            • 19629
            • 21 Posts
            Lol,

            That will be why then.

            Seems okay now. I will run it for a good 48 hours try and save and update as much as possible to see how I get on.

            Thanks for the tip though.

            Regards

              • 19629
              • 21 Posts
              Just for anybody else that has had this problem I can confirm that it was the fact that I was not using fastCGI