-
☆ A M B ☆
- 2,475 Posts
Anyone have this happen? Clicking on "Clear Cache" from the admin menu brings up the modal window, but nothing happens. No errors in the PHP logs. I have to manually refresh the page. Oddly, the MODx logs don’t seem to show... that page doesn’t load correctly, so clearly something else got whacked when I moved servers here.
Any thoughts?
Thanks!
I had a similar issue with one of my projects hosted on a Plesk Parallels server and sometimes the error log utility seems unresponsive. I’m thinking this must be an issue with a setup option at the server level. A needed resource maybe missing or it denied access to. The team members may know something about this.
A MODx Fanatic
Actually, it happens to me fairly regularly on my localhost XAMPP install. I have no idea why, though FF add-ons may play a role.
BTW, in my experience, the cache is not cleared unless you actually see the cache file names in the console.
-
☆ A M B ☆
- 2,475 Posts
You know what I think this is? I think it’s simple permissions issues. This cropped up when I copied a prod site to my local dev server. Then a lot of various admin screens failed to appear. I tried re-running the setup script on the copy of the site, and POOF -- it identified several directories with incorrect permissions (which isn’t surprising when the user/group names have all changed). After I corrected those and completed the setup again, the dev copy of the site worked. It’s possible the setup script did some other magic, but my guess is that it was caused by simple permissions.
What do you think? If I can verify this, it’d be worth a feature request to ask for more thorough permission checking in the manager in day-to-day operations, not just during the setup process.
It’s happening to me on localhost with Windows Vista where I have write access to everything, AFAIK.
Quote from: OpenGeek at Dec 03, 2010, 05:25 PM
It is most likely permission issues in your case Everett. Not convinced BobRay’s issue is the same.
Quote from: BobRay at Dec 03, 2010, 04:53 PM
It’s happening to me on localhost with Windows Vista where I have write access to everything, AFAIK.
If you can decode and understand permissions on Windows, you are a better man than I. 
I certainly can’t make that claim.
But I think any permission problems would show up during setup and I’ve never had that happen.
-
☆ A M B ☆
- 2,475 Posts
Thanks for the response. If I can confirm how and when this happens, I’ll file an improvement request. I’ve been giving some thought to an export script that would package up a MODx install and assist in unzipping/installing the database... so these permissions issues have to be monitored for situations like that.
Quote from: Everett at Dec 04, 2010, 01:38 PM
Thanks for the response. If I can confirm how and when this happens, I’ll file an improvement request. I’ve been giving some thought to an export script that would package up a MODx install and assist in unzipping/installing the database... so these permissions issues have to be monitored for situations like that.
Another reason I don’t think it is a permission issue is that it often happens to me two or three times in a row. I get an empty window in the console on clearing the cache, but the OK button is active. If I click it, I often get the same thing a few more times before it takes. It seems to come and go with various dev versions, and in some it seems to never happen. It seems particularly bad in the current version. If I had time, it would be a good chance to use Git bisect. OTOH, it may have to do with what I’ve been doing before it sets in.