Was working on my testing/development site when the manager returned a blank screen. After rebooting everything, the login screen was almost completely white, but the form fields could be seen. Login apparently worked but showed the following error messages:
Fatal error: require_once() [function.require]: Failed opening required ’model/modx/processors/security/login.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/canprod/public_html/mr2/manager/controllers/default/security/login.php on line 50
Going to the manager error_log file, the following entries were made during (after?) login:
[11-Nov-2010 09:52:38] PHP Warning: PHP Startup: Unable to load dynamic library ’/usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so’ - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
[11-Nov-2010 09:52:50] PHP Warning: PHP Startup: Unable to load dynamic library ’/usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so’ - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
[11-Nov-2010 09:52:50] PHP Fatal error: require_once() [<a href=’function.require’>function.require</a>]: Failed opening required ’model/modx/processors/security/login.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/canprod/public_html/mr2/manager/controllers/default/security/login.php on line 50
system info:
Apache version 2.2.16
MySQL version 5.0.91-community-log
PHP version 5.2.14
Revo 2.0.4pl
I have tried reinstalling by "upgrade", but same result. Any help would be greatly appreciated.
More information: The best I can tell, core_path is not defined or empty. I replaced
$processor = $modx->getOption(’core_path’).’model/modx/processors/security/login.php’;
with
$processor = ’/home/canprod/public_html/mr2/core/model/modx/processors/security/login.php’;
in manager/controllers/default/security/login.php
and manager now starts. Of course, this doesn’t fix the overall problem as nothing else using core_path can be found.
Look in the the config.core.php file in the root to see how the core path is set.
There is also one in setup/includes. If you correct that one and do an upgrade install it might straighten things out.
BTW, I should have asked this earlier, but exactly what were you doing before things went south?
Here are some more things to try:
Check everything in core/config/config.inc.php.
Also take a look for anything suspicious in .htaccess and index.php in the MODx root in case you’ve been hacked.
If those look ok --
Delete everything in the core/cache/ directory except index.php.
Clear your browser cache and cookies, then try running setup again.
Glad it worked.

Thanks for reporting back.
Quote from: zatanax at Jun 09, 2011, 11:43 PM
i pass for the same wen move the site , i made another installation of modx in a subdirectory and view the 2 config.inc.php of the site and discover this
Fatal error: require() [function.require]: Failed opening required ’/home/mesite/public_html/manager/controllers/default/security/login.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/mesite/public_html/core/model/modx/modmanagerrequest.class.php on line 104
example line 24
$modx_core_path= ’/home/newsite/public_html/eh/modx-2.1.1-pl/core/’; v/s $modx_core_path= ’/home/oldersite/public_html/core/’;
change all oldersite for newsite and work .
Did you run Setup after moving the site? That usually straightens out the paths.