We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10638
    • 57 Posts
    I am having a few problems on a new revo site. Redirector and Archivist redirects do not appear to be working at all, although they were previously (this is on a media temple DV). I am starting to worry that the DV is messed up somehow, as migrating the site from my laptop where I created it, to the production server was an absolute nightmare. I followed the guide on rtfm and even then I couldn’t get it to work and ran into big problems. In the end I had to install a clean copy of Revo on the server and manually import the resource content, chunks and tv’s from development database. If no one else has experienced this try it on another server I guess!

    http://www.southernoceansailing.com.au/blog/

    Here is the blog page using Archivist, if you click the october archive all you will get is a blank white page. I have checked the error logs in modx and on the server itself and nothing is showing up.

    I am wondering if this be something related to my .htaccess file. Regular friendly URL redirects are working fine. huh

    Has anyone experienced this kind of thing on a revo site? I am using the latest release (2.0.4-pl2).

    Overall I found revolution a great system to work with. Congrats on the great release.
      • 28215
      • 4,149 Posts
      - Whats the archive Resource content set to?
      - Did you make sure to make the ’Archive’ resource be uncacheable?
      - What version of Revo?
      - Do you have any extra .htaccess rules besides the default MODx ones?
      - Any relevant errors in core/cache/logs/error.log?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 10638
        • 57 Posts
        Hi thanks for your reply, here is the setup.

        - Whats the archive Resource content set to?
              [[!getPage?  
                &element=`getArchives`  
                &elementClass=`modSnippet`  
                &tpl=`blogPost`  
                &hideContainers=`1`  
                &pageVarKey=`page`  
                &parents=`2`  
                &includeTVs=`1`  
                &processTVs=`1`
                &toPlaceholder=`archives`  
                &limit=`10`  
                &cache=`0`  
              ]] 
        


        - Did you make sure to make the ’Archive’ resource be uncacheable?
        Yes the resource is uncacheable.

        - What version of Revo?
        MODx Revolution 2.0.4-pl2

        - Do you have any extra .htaccess rules besides the default MODx ones?
        The only rule besides the defaults is a 301 redirection for the purposes of Google picking up the new URL.
        RewriteRule ^recreational-skippers-ticket$ /skippers-ticket/ [R=301,L]
        


        - Any relevant errors in core/cache/logs/error.log?
        Unfortunately not. The error.log file is completely empty.


        I did at one point enable database caching in the system settings. Is there a way to flush this out somehow? I was wondering if it might be affecting things somehow – just a guess. smiley
          • 28215
          • 4,149 Posts
          Does removing the custom Rewrite rule help any?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 10638
            • 57 Posts
            Thanks for taking a look. This problem was solved by modifying a custom SSL plugin that was being used on the site. Thanks Cipa! smiley