I apologize if this had already been solved, but I didn’t find anything on it.
I am running revo 2.0.4 on a Hostgator shared server. My evo sites all work fine after I put the php.ini file in to turn off register_globals (all on Hostgator shared as well). However, on the two sites I am building with revo, I get a fatal error when I use the same php.ini file.
Fatal error: Class ’PDO’ not found in /home/dental01/public_html/core/model/modx/modx.class.php on line 361
Thanks so much for posting the solution!
I have done the exact same thing, also on a Hostgator shared server. My php.ini file looks like this:
register_globals = Off
extension=pdo.so
extension=pdo_mysql.so
The error message saying the register_globals is on remains.
When looking at my site I only get a white page.
What am I doing wrong?
(Modx Rev 2.0.6(traditional)
Thank you
-
☆ A M B ☆
- 2,213 Posts
Two suggestions, the first, you may want to use this:
http://tips-scripts.com/php_ini
It will copy the current php.ini your host uses and append your changes. This is a better method to do custom php.ini files.
Second, you may need to distribute the custom php.ini file among the folders on your site, so use:
http://tips-scripts.com/php_ini_copy
There is also one to delete them all should you need it
Hi AMDBuilder. Thanks for your scripts. I’m an infant here, and I am not sure what to do with the following:
// full unix path - location of the default php.ini file at your host
// you can determine the location of the default file using phpinfo()
My phpinfo.php file contains the following:
<?php
phpinfo();
?>
Thanks
Okay. I think my problem is with my expectations rather than any code. When I use the "preview" function, everything shows up as it should. When I open a new tab and try to go directly to the site, I get the white page. I expected to see what I had created, and I’m guessing that I haven’t gotten far enough for that yet.