We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21075
    • 24 Posts
    Hey guys-

    Sorry if this question is answered elsewhere, but I haven’t been able to find it.

    I have been using Evolution for about five years and am now building my first site in Revolution. I started on 2.0.3 and just upgraded to 2.0.4 just to see if that would fix my problem. It did not.

    Problem is simple: Whenever I try to create or edit a TV, the TV edit panel just sits there and says "loading..." forever, leaving me unable to edit any of the settings or save the TV.

    I AM able to use the "Quick Create" and "Quick Edit" options, but those obviously do not give me access to all the settings.

    Is this due to a config setting somewhere that I have missed? I’ve found nobody else with this issue, so I can’t shake the feeling that it’s a simple thing I’m overlooking, but maybe not. I have no trouble creating any other types of elements.

    My site is hosted on a GoDaddy Linux server.
    MySql 5.0, Php 5

    I am experiencing this problem in both FF 3.6.10 and Opera 10.62.

    Thanks in advance.
    -Steve
      • 28215
      • 4,149 Posts
      Can you give us all the following:
      Note: If you’re posting about a bug, please state all of your Environment information in your post: Version of MODx, Traditional or Advanced distribution (for Revo), Server OS, Server Version, PHP Version, MySQL Version (client and server), is pdo_mysql installed, your Browser type and version, if you are using any opcode caching such as eAccelerator, APC, winCache, xCache, etc; any relevant errors in core/cache/logs/error.log, and any other environment data we should know. We can’t help you without that information.

      Also, what *specific* versions of PHP and MySQL. And are there any JS errors when you save?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 21075
        • 24 Posts
        Okay-

        Linux 2.6.18-164.15.1.el5PAE
        PHP 5.2.14
        MySQL server 5.0.91-log
        MODx 2.0.4-pl2 (traditional)
        pdo_mysql is installed


        Found quite a few lines that look like this in my error.log. Timestamp indicates they’re from when I upgraded:
        [2010-10-18 18:29:47] (ERROR @ /setup/index.php) Could not copy /home/content/s/i/n/sincookieadmin/html/core/packages/core/modContext/b27600ea131d2caa13381998bbce79b1/4/ to /home/content/s/i/n/sincookieadmin/html/manager/index.php
        [2010-10-18 18:29:47] (ERROR @ /setup/index.php) Could not install files from /home/content/s/i/n/sincookieadmin/html/core/packages/core/xPDOFileVehicle/e461ebd2df78ea562f536b233e490b9d/ to /home/content/s/i/n/sincookieadmin/html/connectors/



        No js errors when I save a resource. Obviously, I can only save a TV using the Quick Edit feature - no errors there either.
          • 3749
          • 24,544 Posts
          Looks like a permission issue. Some of your directories were not writable so some key files didn’t get upgraded (but the old ones are still there so it sort of works).

          Possibly your host implemented suPHP or suExec (or some other security system) between the installs.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 22303 MODX Staff
            • 10,725 Posts
            Quote from: BobRay at Oct 19, 2010, 12:08 AM

            Looks like a permission issue. Some of your directories were not writable so some key files didn’t get upgraded (but the old ones are still there so it sort of works).

            Possibly your host implemented suPHP or suExec (or some other security system) between the installs.
            With traditional distro’s this shouldn’t matter as long as the files were uploaded properly (and no corruption occurred to any of those files during the upload).
              • 21075
              • 24 Posts
              @BobRay- yeah, that was my first thought as well when I saw the log, but I don’t think so. I was having the problem before I upgraded, not only after. I should also clarify that some of the timestamps are from my original install and some are from the upgrade. So why would everything install properly except whatever part of the system is supposed to make the edit TV panel finish loading?

              I’m not the expert on these things, so anyone having any ideas, please offer them. I don’t have a ton of code on this site yet and GoDaddy has a tool that will install MODx automatically, so if I can’t figure this out in the next little bit of time, I’m just going to copy out all my existing code, run a fresh install using their tool, and recreate the site. I’d rather know what the problem is though.

              Thanks guys.
                • 21075
                • 24 Posts
                Okay. I went ahead and reinstalled, this time on 2.0.2-pl (which is what GoDaddy’s setup tool is using and now things are working. I’ll upgrade in a while and hope it still works then. I have no idea what the problem was, but at this point I just need to get the sit finished. Thanks everyone!