We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12793
    • 293 Posts
    Hi! I’ve moved Modx Revo from one server to another server.... I’ve found all package installed on old server and I want to delete for reinstall...

    I show this error:

    MODx could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    Could not load transport package.
    MODx could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    Package found. Preparing to uninstall.
    Could not transfer package ckeditor-0.1-rc2.transport.zip to /home/xxxsss/httpdocs/xxx/core/packages/.
    Finding package with signature: ckeditor-0.1-rc2
    Could not open file for reading: ckeditor-0.1-rc2.transport.zip?revolution_version=Revolution-2.0.3-pl
    Could not transfer package ckeditor-0.1-rc2.transport.zip to /home/xxxsss/httpdocs/xxx/core/packages/.
    Could not open file for reading: ckeditor-0.1-rc2.transport.zip?revolution_version=Revolution-2.0.3-pl

    Why??
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Your new server has to be configured to permit remote file access, as the error states:
      You must enable allow_url_fopen, cURL or fsockopen
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 12793
        • 293 Posts
        it’s already activated
          • 26171
          • 1 Posts
          I had this same problem. It occurs when you are, say, building your site in a test folder and then moving it to a production folder - there is a variable which governs where the packages are supposed to be stored and this is not automatically generated but stored in a database. Since you are moving from one server to the other, this variable is now outdated and points to the wrong directory. Check your `_workspaces` table on your MODx DB and correct the entry "Default MODx Workspace" to the valid core directory. Honestly, why MODx doesn’t just use the automatically generated MODX_CORE_PATH I have no idea.