After I upgraded one of our sites to 2.0.3 the snippets of that site (multi-context) won’t generate any output.
While trying to solve the problem, I created a very simple test template:
The snippet:
<?php
return 'Hello world!'; //tried echo as well
The output:
So it looks like the snippet is not parsed at all. The error log is empty. Cache has been cleared multiple times.
Anybody knows why my snippets don’t work anymore?
Environment:
MODX 2.0.3
Apache 2
PHP 5.2.13
CentOS 5
Solved: I restored index.php because I uploaded it over a customized one, loosing all the custom work. But after the restore the file got owned by root instead of the user. After changing the ownership to the user everything worked as expected.