We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14605
    • 40 Posts
    Hey I have just moved a site from my development machine to a linux web server... I have made the config changes however, the gallery package is still holding onto the base path from my local install (see bold in below error message)...

    How can I change this? I’ve deleted the core/cache directory and edited config.inc.php to show my web server path, rather than my local path... Am i missing something else?

    [2010-10-06 16:23:21] (ERROR @ /modx/manager/index.php) Could not load class: Gallery from gallery.
    [2010-10-06 16:23:21] (ERROR @ /modx/manager/index.php) Problem getting service gallery, instance of class Gallery, from path C:\xampp\htdocs\modx/core/components/gallery/model/gallery/
    [2010-10-06 16:23:25] (ERROR @ /homepages/16/d90110625/htdocs/home/php/v2/v3/modx/core/model/modx/modtemplatevar.class.php : 422) PHP warning: DirectoryIterator::__construct(C:\xampp\htdocs\modx/core/components/gallery/elements/tv/input/) [<a href=’directoryiterator.--construct’>directoryiterator.--construct</a>]: failed to open dir: No such file or directory
    [2010-10-06 16:23:25] (ERROR @ /homepages/16/d90110625/htdocs/home/php/v2/v3/modx/core/model/modx/modtemplatevar.class.php : 422) PHP warning: DirectoryIterator::__construct(C:\xampp\htdocs\modx/core/components/gallery/elements/tv/input/) [<a href=’directoryiterator.--construct’>directoryiterator.--construct</a>]: failed to open dir: No such file or directory
      • 28215
      • 4,149 Posts
      Check the Gallery namespace path. Make sure it’s using the new one.

      Also, make sure you copied the core/components/ directory.

      And finally, upgrade to Revo 2.0.3.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 14605
        • 40 Posts
        Where can i find the Gallery namespace path??

        Many thanks
          • 28215
          • 4,149 Posts
          System -> Namespaces.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 14605
            • 40 Posts
            Can’t get that far, as the modx initialization is stopping after failing to load the gallery package...

            However, I found some settings in modx/core/cache/config.cache.php that held the old values (c:\xampp), which seems to have done the trick...
              • 14605
              • 40 Posts
              I found the c:\xampp settings were all stored in System > System Settings...

              Thank you for your help