We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 32460
    • 11 Posts
    Error:
    Could not download package at: http://modxcms.com/assets/components/releaseme/dl.php?file=1584

    When trying to download a package through the package manager, I get the message above. I don’t see any other error messages. The packages seem to be there, I can get details on the packages. I have tried a number of packages but they all do the same. Perhaps there is a setting or something I missed? Or do I need to change permissions on some folder(s)?


    MODx 2.0.3
    x86_64 Redhat Linux Apache 2.0 Handler 20051115 PHP Version 5.2.13 MySQL Server Version: 5.0.66a-log MySQL Client Version: 5.0.66a Firefox 3.6.10



      • 28215
      • 4,149 Posts
      splittingred Reply #2, 16 years ago
      Do you have cURL installed?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 32460
        • 11 Posts
        curl is enabled, curl information: libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

        curl modules availible: curl_init, curl_copy_handle, curl_version, curl_setopt, curl_setopt_array, curl_exec, curl_getinfo, curl_error, curl_errno, curl_close, curl_multi_init, curl_multi_add_handle, curl_multi_remove_handle, curl_multi_select, curl_multi_exec, curl_multi_getcontent, curl_multi_info_read, curl_multi_close

        I should mention this is on a shared host, if that matters.
          • 28215
          • 4,149 Posts
          splittingred Reply #4, 16 years ago
          It might. Can you verify the core/packages/ directory is writable?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 32460
            • 11 Posts
            It was 755. I changed it to 777 but still nothing.
              • 32460
              • 11 Posts
              [2010-10-04 07:24:21] (ERROR @ /modx/connectors/workspace/packages-rest.php) Could not open file for reading: http://modxcms.com/assets/components/releaseme/dl.php?file=1337&revolution_version=Revolution-2.0.3-pl
              [2010-10-04 07:24:21] (ERROR @ /modx/connectors/workspace/packages-rest.php) MODx could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
              [2010-10-04 07:24:21] (ERROR @ /modx/connectors/workspace/packages-rest.php) Could not download package at: http://modxcms.com/assets/components/releaseme/dl.php?file=1337
              


              From the MODx log.
                • 32460
                • 11 Posts
                Ah-ha! Success! Turns out I missed a place where curl was disabled, but I was able to enable url-fopen instead. Thank you for your help, Shaun!