We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    @star_faeiz: thanks for sharing that information

    FYI, I’ve reopened the original ticket for this at MODX-2100; it appears that tertiary logic is not working properly, though I’m still curious why it is only affecting some environments.

    Quote from: webandflow at Sep 29, 2010, 08:30 AM

    UPDATE: This behavior (not appending file extension) seems to be browser specific now.... Chrome/Safari append the .pdf, Firefox does not (cleared cache, etc). Haven’t tried in IE yet.. IE does not append the extension either.

    @opengeek: does this make sense? I don’t understand why this would work on some configs and not others.
    I don’t understand yet either; are you using this without friendly_urls enabled? If so, there may be an additional problem that needs to be solved when delivering these Content Types with friendly_urls disabled.
      • 32070
      • 87 Posts
      @opengeek: Interesting you should ask about friendly-urls.....

      Up until now in this thread, I’ve been accessing these resources by resource id (index.php?id=x) in both shared hosting scenarios (both GoDaddy). One of these sites does, in fact, have friendly URLs enabled, so I tried to access it that way. Instead of a 500 error, it simply sends me to the site_start page. Not seeing anything show up in the MODx error log when trying to access via friendly url.

      I’m going to upgrade this site to 2.0.3 today and will check it out again, but I’m assuming I’ll get the same results.... I’ll keep you updated.
        Des
        webandflowdesign.com
        • 22303 MODX Staff
        • 10,725 Posts
        Ok, the only problem I can find is if you have gzip compression enabled in your PHP configuration and you try to use inline with PDF files, because the filename is always index.php and something happens in this case when you have
        zlib.output_compression On


        I cannot reproduce any problem with the tertiary logic or downloads of the files in any other circumstances, and the code posted in regards to switching the tertiary logic simply reversed inline and attachment dispositions, which is not correct either.

        Please use the bug report, #MODX-2100 to provide any additional information (complete response headers would be appreciated from environments where this fails) that can help track down why some people are having problems with this and others are not.
          • 19795
          • 1 Posts
          See http://bugs.modx.com/issues/313 for a quick fix of this issue.
            • 32070
            • 87 Posts
            Awesome. Looks like this will be fixed in 2.0.5...

            I was about to post that I was having the same issue again, but this time with the RSS content type. When I change content type to RSS, I was getting the same internal server error.

            I’ll make the change in my code outlined in JIRA and wait for 2.0.5.

            UPDATE: This is still only valid when friendly URLs are disabled - it’s works fine when I try to access http://www.webandflowdesign.com/?id=37 but not when I try www.webandflowdesign.com/rss
              Des
              webandflowdesign.com
              • 16863
              • 29 Posts
              I worked around for the time being by changing the static resources to weblinks. Feels hacky, but hey, it works.
                • 44268
                • 3 Posts
                Everything would be solves once you download a pdf process assistance.It can download pdf,edit pdf and process pdf as you wish