-
☆ A M B ☆
- 450 Posts
I was bumbling around with a Revo 2.0.0 site this morning, in a sleep-deprived stupor, and I must have done something very very wrong. I lost my manager session, and can’t log back in with my admin account - I get the "That account could not be located" message... Also, my front end / web context stopped working right - every request sends me to my error page.
I’ve been trying to look at the db tables and compare them to another stable installation, but so far nothing has looked out of the ordinary. I deleted a ton of session records in the modx_session table (which I found odd that there were so many accumulated), but that didn’t help.
My admin user account seems to be intact, and my resources all seem to be intact. Can’t see any reason at all why this is happening.
Is there anything obvious I should be looking for?
Try re-running setup and see if that helps.
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
-
☆ A M B ☆
- 450 Posts
Problem solved.
I used the crappy database admin interface provided by my hosting provider to add a new MySQL user... or so I thought. I chose the same username as the existing one that MODx uses, but a different password... so it just reset the password for the existing user account and hence the db connection was failing.
I had been doing a bunch of other stuff too - just upgraded a bunch of packages, and was testing a 3rd-party authentication add-on, so I had no idea what might have been the culprit. Turns out upgrading to 2.0.2 did solve my problem, if only because the install choked because it couldn’t connect to the database.
Its been at least a week since I’ve had one of these ’nevermind’ posts... guess I was overdue.