We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14883 ☆ A M B ☆
    • 450 Posts
    I was bumbling around with a Revo 2.0.0 site this morning, in a sleep-deprived stupor, and I must have done something very very wrong. I lost my manager session, and can’t log back in with my admin account - I get the "That account could not be located" message... Also, my front end / web context stopped working right - every request sends me to my error page.

    I’ve been trying to look at the db tables and compare them to another stable installation, but so far nothing has looked out of the ordinary. I deleted a ton of session records in the modx_session table (which I found odd that there were so many accumulated), but that didn’t help.

    My admin user account seems to be intact, and my resources all seem to be intact. Can’t see any reason at all why this is happening.

    Is there anything obvious I should be looking for?
      • 5340
      • 1,624 Posts
      Try upgrading to 2.0.2 or later from git.
      http://rtfm.modx.com/display/revolution20/Git+Installation
        • 28215
        • 4,149 Posts
        splittingred Reply #3, 16 years ago
        Try re-running setup and see if that helps.
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 22303 MODX Staff
          • 10,725 Posts
          Quote from: jrotering at Sep 21, 2010, 10:53 AM

          I was bumbling around with a Revo 2.0.0 site this morning, in a sleep-deprived stupor, and I must have done something very very wrong. I lost my manager session, and can’t log back in with my admin account - I get the "That account could not be located" message... Also, my front end / web context stopped working right - every request sends me to my error page.
          I’m afraid in order to help I’m gonna have to know more specifics about the bumbling you were doing, or any errors being produced in the logs, or something that might indicate what the problem is; at least If running the upgrade doesn’t help.
            • 14883 ☆ A M B ☆
            • 450 Posts
            Problem solved.

            I used the crappy database admin interface provided by my hosting provider to add a new MySQL user... or so I thought. I chose the same username as the existing one that MODx uses, but a different password... so it just reset the password for the existing user account and hence the db connection was failing.

            I had been doing a bunch of other stuff too - just upgraded a bunch of packages, and was testing a 3rd-party authentication add-on, so I had no idea what might have been the culprit. Turns out upgrading to 2.0.2 did solve my problem, if only because the install choked because it couldn’t connect to the database.

            Its been at least a week since I’ve had one of these ’nevermind’ posts... guess I was overdue.

              • 22303 MODX Staff
              • 10,725 Posts
              Quote from: jrotering at Sep 21, 2010, 12:08 PM

              Its been at least a week since I’ve had one of these ’nevermind’ posts... guess I was overdue.
              No worries; as the Chinese proverb goes, "he who asks is a fool for five minutes, but he who does not ask remains a fool forever", and I often find I solve things myself within 5 minutes of asking such questions. wink