Hi. I need a help.
I was happy with my installation of MODx on my home server and after a time was going to install ready site on production server,
but run into unexpected problem there...
Environment:
Linux s3.1ps.ru 2.6.34-gentoo-r6
PHP Version 5.2.14-pl0
Mysql server version: 5.1.47
pdo_mysql installed (and connection test passed
no eaccelerator and so on
Traditional distribution MODx Revolution 2.0.0-pl
Installation was totally successfull with no errors on setup screen, but I noticed some errors in "core/cache/logs/error.log"
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/0/ to index.php
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/1/ to ht.access
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/0/ to assets
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/1/ to controllers
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not copy /home/mysite/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/c9366179780330a60397dc65652071a9/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/70496e8c8b2f20b1a5475b6a53d8ae08/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/62dfa0c3aa4f49d0842fcd1e508daddb/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/d095a33f0877ac62fc7e084c26b68f9b/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to
[2010-09-10 08:37:53] (ERROR @ /setup/index.php) Could not install files from /home/mysite/public_html/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to
And finally, after trying to log in to /manager/ I got "502 Bad Gateway" from nginx (although using Apache for PHP), SIGSEGVs in "/var/log/messages" and one more error in "core/cache/logs/error.log"
[2010-09-10 08:39:28] (ERROR @ /manager/index.php) Error preparing statement for query: SELECT `modActionDom`.`id` AS `modActionDom_id`, `modActionDom`.`action` AS `modActionDom_action`, `modActionDom`.`name` AS `modActionDom_name`, `modActionDom`.`description` AS `modActionDom_description`, `modActionDom`.`xtype` AS `modActionDom_xtype`, `modActionDom`.`container` AS `modActionDom_container`, `modActionDom`.`rule` AS `modActionDom_rule`, `modActionDom`.`value` AS `modActionDom_value`, `modActionDom`.`constraint` AS `modActionDom_constraint`, `modActionDom`.`constraint_field` AS `modActionDom_constraint_field`, `modActionDom`.`constraint_class` AS `modActionDom_constraint_class`, `modActionDom`.`active` AS `modActionDom_active` FROM `modxrev_actiondom` AS `modActionDom` LEFT JOIN `modxrev_access_actiondom` `Access` ON `modActionDom`.`id` = `Access`.`target` WHERE ( `modActionDom`.`action` = ? AND `modActionDom`.`active` = ? AND ( ( `Access`.`principal_class` = ? AND `Access`.`principal` IN (1) ) OR `Access`.`principal` IS ? ) ) Array
(
[0] => 42000
[1] => 1064
[2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '? ) )' at line 1
)
What I should ckeck or what else can I do for now to run MODx on that server?
Btw, I noticed similar bug report on
http://bugs.modx.com/browse/MODX-2014, but I cannot start it as not a member.