hmm I think I may have found a bug?
When linking to files on the server in a directory "blah & blah"/file.pdf the second attempt will replace the file tree (under both the file tab or the modx browser ) with the error message "Please select a valid directory"
I believe this is due to the file tree trying to expand the folder with the ampersand in the file name. (I haven’t done any checking of other odd characters in folder names)
Environment:
revo 2.00pl rev7212 traditional
mysql 5.1.48 (client api version 4.1.22)
php 5.2.13 suPHP
apache 2.0.52
pdo_mysql installed
no opcode
no relevant errore
most testing done in google chrome
|