Hi all,
I’m having nothing short of a nightmare setting up MODx Rev (modx-2.0.0-pl) on a shared hosting account. If it’s not file permissions, it’s something else. Installation started and I thought all was going well until I was filling out the form to specify my db connection and when Testing database connections I get the error
Connecting to mysql server:
Could not connect to the database server. Check the connection properties and try again.
[2010-09-03 13:31:08] (ERROR in xPDO::connect @ /hsphere/local/home/[username]/[site]/core/xpdo/xpdo.class.php : 305) could not find driver
[2010-09-03 13:31:08] (ERROR in xPDO::connect @ /hsphere/local/home/[username]/[site]/core/xpdo/xpdo.class.php : 305) could not find driver
Now this means nothing to me. I’m running Apache on Linux with PHP 5.2.9 and MySQL 5.0.77. In my phpinfo, PDO is enabled:
’--enable-pdo=shared’ ’--with-pdo-sqlite=shared’ ’--with-pdo-mysql=shared’
PDO
PDO support enabled
PDO drivers mysql, pgsql, sqlite, sqlite2
pdo_mysql
PDO Driver for MySQL, client library version 5.0.67
Does anyone have any ideas how to fix this? This has totally stumped me. I’ve read posts about fiddling around with php.ini etc but that doesn’t work for shared hosting, obviously.
Thanks in advance
Leo.
-
☆ A M B ☆
- 265 Posts
I just got this same error when trying to install Revo on a clients server:
Connecting to mysql server:
Could not connect to the database server. Check the connection properties and try again.
[2010-09-07 14:12:21] (ERROR in xPDO::connect @ /www/sites/58e/4e3/www.[domain-name].co.uk/web/newsite/core/xpdo/xpdo.class.php : 305) SQLSTATE[28000] [1045] Access denied for user ’username_’@’10.1.4.82’ (using password: YES)
[2010-09-07 14:12:21] (ERROR in xPDO::connect @ /www/sites/58e/4e3/www.[domain-name].co.uk/web/newsite/core/xpdo/xpdo.class.php : 305) SQLSTATE[28000] [1045] Access denied for user ’username_’@’10.1.4.82’ (using password: YES)
I did notice that in the error the username is cut short as "username_" whereas the full username is "username_co_uk_db"; could the xpdo.class.php file be falling over when it hits the first underscore in the database username?
MODX Ambassador for Thailand. Managing Director at
Monogon, a web design and development studio based in Bangkok, Thailand. -
Follow me on Twitter.
I have the same problem. Remove all underscores from names. Again, shared hosting.
I certainly think the problem is something like that. I created a brand new mysql user and this seems to have solved it. Heaven knows why they chose this approach for connecting to mysql but anyway. Resolved?...
I have precisely the same problem. In my case the shared hosting automatically adds an underscore to the db user name, so there is not possibility of removing it. I know next to nothing about php and am finding Modx to be a complete swine to install. As a complete novice to Modx I must say that the installation instructions seem hopeless incomplete (basically; run setup, let Modx try to create database, which may fail (sure does) then create a database manually, create user etc. Run install again. Fail.
Try to run again and now server 500 error. What???
Why does it have to be so complex?
Trying to install Revo 2.0.4
Linux server