We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 4357
    • 9 Posts
    I have a Win2003 server running one MODx Revo site. This site runs fine using IIS6, FastCGI, PHP 5.3.3, MySQL 5.1.49 and ISAPI/Rewrite of Helicon.
    Now I want to add a second MODx site on that same server. I think I could just create a new folder, download Revo in it and run the setup using another database in MySQL.
    But, installation fails. The install program starts fine and the Installation Summary states everything as OK!.
    When I click the Install button I receive a 500 Error: A fatal application error has been encountered.

    Do I have to take special precautions when installing/running multiple MODx sites on one IIS server?

    My php-errors.log ends with:
    PHP Fatal error: Call to a member function install() on a non-object in C:\Inetpub\<website folder>\setup\includes\modinstall.class.php on line 358


    Edit: SOLVED. The "Internet Guest Account" of IIS just didn’t have enough access to the new folder!


    Kind regards,
    Maurits, The Netherlands