I’m getting this javascript error when installing. As soon as it connects to mysql and I click on the "create or test selection of your database" link.
Message: Expected ’]’
Line: 9
Char: 80543
Code: 0
setup/assets/js/ext-core.js
I cant’t get passed this error. Any Advice? I;ve tried uploading the file again from the download.zip but no help.
after hours of trying to figure this out somehow it worked. I created a new database, uploaded the setup/assets dir again and it just worked. Very odd. the error probably wasnt even restopping the install. It mayhave been mydb settings. Not sure though.
I am experiencing EXACTLY the same problem, but your fix is not working for me. Anyone else got any solutions?
I am uploading with Filezilla and everynow and then it asks me if I want to replace the file on the server with the new one? What is all that about, especially when uploading to a clean server, I don’t get it.
-
MODX Staff
- 10,725 Posts
This was probably the result of a failed FTP upload. Happens all the time.
I had a weird situation. I tried installing on my Local machine XP IIS 5.1. Everything installed fine, but when I tried to login, it stopped IIS from running. I re-read the install instructions and it said I needed IIS 6 which from what I can find, cannot be installed on XP. So I decided to test in in a subdomain.
I had FTP issues, kept timing out and I had too many cleints logged in. (somethign weird that I;ve never experienced, contacted host and I assumed they cleared all ftp connections, so I continuited)
I Created the modx DB using navicat MySQL prior to installing on the subdomain (using HTTP tunneling since they do not allow remote connections [loosers]). I think this is where the probalem lies. When I logged into my web control panel, I could not see the new mysql db, but when I tried to create it, it says it already existed (duh, I created it with navicat). So in the install, I tried to connect to the modx DB. It would connect, but the "verify colation..." step would not work.
I re-uploaded the directory that was giving me the .js error ( because I thought this was the problem), but still no go. I decided to try a new db. This time I created it though the control panel on my host, called it devx. I restarted the set up process and used the new devx db. The javascript error notification still showed up, but the install process continued without a hitch. No db errors or collation errors.
I’m still not 100% sure what the issue was, but it may have been the way I created the database. Hope this helps anyone or sparks some thoughts on what could be the problem.
I get the same error, so far no resolution. It seems like a pretty silly thing for a javascript error to make an installation fail. I would like to use the CMS for my project and have even contributed, is there a resolution for this?
I did create the database, but cannot get past the "Connection Information" screen due to this error. I am using Firefox 3.6.13 on Snow Leopard.
While testing out a few other non-modx applications I noticed that the way I created the DB seems to cause a problem. My Host doesn;t explicitly allow remote mysql connections. So I have to use thier control panel to create a DB. But for the original install that gave me errors I created the DB using Navicat with a connection using http tunelling. There must have been an issue with that and setting the proper collation settings. Because after I re-installed it, but after creating a new DB using the hosts control panel, it worked.
Not sure if you are using a remote applicaiton to create the db or not, but maybe dig around those issues. My hosts has an applicaiotn in thier controal panel that lets me do some stuff and then conencts me to phpmyadmin.
Hope that help. Modx is pretty sweet. I’ve enjoyed working with it a lot. Makes my life easier.