Until now I had 2 problems installing MODx Revolution 2.0.0-pl-Advanced
For the installation I used standard dirs for /core/, /manager/ and /connectors/
but used custom config key.
First issue:
The check if the web dir is writeable fails, though all other checks for writeable dirs are successful.
After a lot of tries I solved the issue by patching the file /setup/includes/checks/modinstalltestadvanced.class.php
Details can be found in this thread
http://modxcms.com/forums/index.php/topic,53420.msg309497/topicseen.html#msg309497
Second issue:
After successful install, I get a all blank page when I try to access the /manager/
I solved the problem by modifying the file /manager/config.core.php
This file still had the MODX_CONFIG_KEY = ’config’ and I changed it’s value to my custom key.
Now the manager login appears as expected.
Lets see what’s coming next.