We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26383
    • 2 Posts
    hello everybody,

    I wanted to install Modx Revolution 2.0.0 PL local in Xampp 1.7.3a with Apache 2.2.14 PHP 5.3.1, MySQL 5.1.41, eAccelerator 0.9.5.3 under Debian-Sid with Kernel 2.6.34, in iceweasel (firefox) 3.5.11 .
    I have created a datebase named "modx" with kollation utf8_general_ci and a user with full acces to this database, grant and passwort in phpMyAdmin.
    In the installation-routine I pressed my username and the corresponding passort for the database.
    After cklicking on "Test database server connection and view collations." I get shown the message:
    Connecting to mysql server:
    Could not connect to the database server. Check the connection properties and try again.

    [2010-08-20 14:18:48] (ERROR in xPDO::connect @ /opt/lampp/htdocs/modx/core/xpdo/xpdo.class.php : 305) SQLSTATE[HY000] [2002] argument not valid

    [2010-08-20 14:18:48] (ERROR in xPDO::connect @ /opt/lampp/htdocs/modx/core/xpdo/xpdo.class.php : 305) SQLSTATE[HY000] [2002] argument not valid

    I can’t find any error.log in /core/cache/
    How I could find out, if pdo_mysql ist installed in xampp and if not, how to Install?

    with modx evolution I hadn’t these problems.
    How can I solve them? Many thanks.

    nice day
    S.I.
      • 21841
      • 36 Posts
      Hi,

      I had exactly the same problem which was solved by editing the php.ini file.

      This can be found in /opt/lampp/etc

      Edit this file and find pdo_mysql.default-socket and change to pdo_mysql.default-socket=/opt/lampp/var/mysql/mysql.sock

      You will still need to use phpmyadmin to create the modx database but the script will then go on and complete the installation OK.

      Hope this helps,

      NWJ
        • 3749
        • 24,544 Posts
        I think there is still an issue with Revolution and eAccelerator, so that may be a factor.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 26383
          • 2 Posts
          Jippiiie! That works.
          Thank you very much Nowhinjing.

          Grettings SI
            • 19374
            • 41 Posts
            It doesn’t work for me :-( with the pdo_mysql.default-socket=/opt/lampp/var/mysql/mysql.sock


            Here is my thread: http://modxcms.com/forums/index.php/topic,59871.0.html