thanks Bob,
I’m fairly certain the error is mine, I’m not sure how I did it though
but for certain, the identical settings that work on one server don’t work on another server, i took my "offline" install, uploaded it, cleared the cache made changes in config and all that, load the manager and same bug.
basically i’ve allocated permissions to every category there is, and it seems that while the Admin has access offline, on my online server he doesn’t.
I found that elements should use the Element ACL so I corrected my errors there.
Would anyone know if it’s normal behaviour that once a category has been assigned to a higher level user group that the lower levels including the SuperUser would no longer have access to that category?
example: (user/usergroup/role/acl)
admin/Administrator/Super User/Administrator
if i set category access for the admin user group, and add all categories, when i flush permissions/clear cache/log out and back in everything is blocked, i can’t see the resources/files/elements trees on the left, nothing on the right, and any menu item I click on logs me out.
only way to fix is to manually delete the entries from the database using phpMyAdmin