We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21893
    • 113 Posts
    Hi,
    I just installed Revolution on a new account, and Im facing now a problem with the install of packages.

    I can download the package, but if I try to install, it says "Package not found". But if I try to download again, it says "Your already downloaded the package". The package-folder is empty

    In the documentation I found:
    Most issues can be resolved by making sure you have cURL installed, and that the core/packages/ directory is writable by PHP
    The right of core/packages are 755 but I dont know how to use "cURL". Besides this, on an other account (different provider) I do not have the problem.

    Can somebody help me?

    Thanks
      Smile, it confuses people!
      • 1778
      • 659 Posts
      cURL is a PHP extension, you should activate it in your php.ini

      Hope this helps...
      Cheers
        • 21893
        • 113 Posts
        Hi anso,

        thanks for the fast reaction. My php-knowledge is very poor. The php.ini does not belong to modx but to the php-installation on the server of my provider right?
        Is there a possibility to get information about the used php and the extensions?

        Thankx
          Smile, it confuses people!
          • 21893
          • 113 Posts
          OK, got it how to get the phpinfo.

          cURL is enabled, so that cant be the problem.

          Any other ideas what can cause the problem?

          Thanks to all

          Frogfish
            Smile, it confuses people!
            • 4971
            • 964 Posts
            Two long shots that I can think of...

            1) Did you created the assets/components directory?
            I think that this is where the components are going to be installed

            2) Do you have all the right permissions?


            (now that I think of it, let me go investigate, cause I think there is
            a difference between components and packages, back in a while with more info).

            Edit:
            a) components and plugins go to assets/components
            b) all packages go to core/components (even plugins and components)

            check the permissions...
              Website: www.mercologia.com
              MODX Revo Tutorials:  www.modxperience.com

              MODX Professional Partner
              • 21893
              • 113 Posts
              Hi Charlize,

              i doublechecked the permissions, (packages to to core/packages) and I compared with the working installation at the other provider, I cant find a difference.

              I think I first of all will start a new installation, then I will be back again ;-)

              Thankx Frogfish
                Smile, it confuses people!
                • 21893
                • 113 Posts
                Hi again,

                a new installation didnt brought success at all. Now I do have the zip-files in the core/packages Folder, but the packages are still not found.

                Is it possible that the long path is a problem (its the only difference to the other account) I tried the installation in a subdomain, that why the path is a little bit odd.

                Edit: I tried a second installation in the regular domain, same problem!

                Error Log:

                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/0/ to index.php
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/1/ to ht.access
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/0/ to assets
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/1/ to controllers
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not copy /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/c9366179780330a60397dc65652071a9/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/70496e8c8b2f20b1a5475b6a53d8ae08/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/62dfa0c3aa4f49d0842fcd1e508daddb/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/d095a33f0877ac62fc7e084c26b68f9b/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to
                [2010-08-11 20:49:26] (ERROR @ /setup/index.php) Could not install files from /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to
                [2010-08-11 20:50:18] (ERROR @ /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/model/modx/transport/modtransportpackage.class.php : 259) PHP warning: curl_setopt() [<a href=’function.curl-setopt’>function.curl-setopt</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set
                [2010-08-11 20:50:19] (ERROR @ /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/xpdo/compression/xpdozip.class.php : 142) PHP warning: ZipArchive::extractTo() [<a href=’ziparchive.extractto’>ziparchive.extractto</a>]: Unable to access /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages//wayfinder-2.1.1-rc1/modSnippet/5af2915ab23f4ab4fafaf1efc49e9b95/0/wayfinder/configs
                [2010-08-11 20:50:19] (ERROR @ /connectors/workspace/packages-rest.php) Could not unpack package /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/wayfinder-2.1.1-rc1.transport.zip to /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/. SIG: wayfinder-2.1.1-rc1
                [2010-08-11 20:51:10] (ERROR @ /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/xpdo/compression/xpdozip.class.php : 142) PHP warning: ZipArchive::extractTo() [<a href=’ziparchive.extractto’>ziparchive.extractto</a>]: Unable to access /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages//wayfinder-2.1.1-rc1/modSnippet/5af2915ab23f4ab4fafaf1efc49e9b95/0/wayfinder/configs
                [2010-08-11 20:51:10] (ERROR @ /connectors/workspace/packages.php) Could not unpack package /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/wayfinder-2.1.1-rc1.transport.zip to /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/. SIG: wayfinder-2.1.1-rc1
                [2010-08-11 20:51:10] (ERROR @ /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/xpdo/compression/xpdozip.class.php : 142) PHP warning: ZipArchive::extractTo() [<a href=’ziparchive.extractto’>ziparchive.extractto</a>]: Unable to access /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages//wayfinder-2.1.1-rc1/modSnippet/5af2915ab23f4ab4fafaf1efc49e9b95/0/wayfinder/configs
                [2010-08-11 20:51:10] (ERROR @ /connectors/workspace/packages.php) Could not unpack package /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/wayfinder-2.1.1-rc1.transport.zip to /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/. SIG: wayfinder-2.1.1-rc1
                [2010-08-11 20:51:52] (ERROR @ /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/xpdo/compression/xpdozip.class.php : 142) PHP warning: ZipArchive::extractTo() [<a href=’ziparchive.extractto’>ziparchive.extractto</a>]: Unable to access /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages//wayfinder-2.1.1-rc1/modSnippet/5af2915ab23f4ab4fafaf1efc49e9b95/0/wayfinder/configs
                [2010-08-11 20:51:52] (ERROR @ /connectors/workspace/packages.php) Could not unpack package /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/wayfinder-2.1.1-rc1.transport.zip to /var/www/virtual/xxxxx.de/revolution_xxxxx_de/htdocs/core/packages/. SIG: wayfinder-2.1.1-rc1

                Any more Ideas??

                Thanks
                  Smile, it confuses people!