You can download/install a revo sample site with Package Manager (under Site Packages).
I’ve had this problem a while ago and used remote connection, and then still had errors. So i figured I would wait until these issues get ironed out. I installed without any issues on my wamp, but came across this issue again with the latest Revolution (2.0.3)
I’m glad "localhost;unix_socket=/tmp/mysql5.sock" worked
thanks for posting the topic and solution!!!!
I’m dumbfounded though why this was never an issue with Evo
you enter it into the database location
usually localhost is enough, but had to enter localhost;unix_socket=/tmp/mysql5.sock for modx revo
-
MODX Staff
- 10,725 Posts
Though using the socket in the DSN will work, this should really be fixed in the php configuration on the server. I would insist they fix this or find a host that understands all of the complexities of configuring a PHP environment that includes PDO MySQL.
This is probably a pointless post, but I’m still having an issue with connecting to a 1&1 database. When I saw this thread, and saw a solution had been posted, I thought it would all be fine, but alas, still issues.
As far as I’m aware, the database name, username and password that have been provided to me are correct.
However, when I try the following details:
Database Host: localhost;unix_socket=/tmp/mysql5.sock
Database login name: mydbloginname
Database password: mydbpassword
Database name: mydbname
I get the error:
Could not connect to the database server. Check the connection properties and try again.
[2011-01-25 10:54:56] (ERROR in xPDO::connect @ /homepages/27/d204533922/htdocs/sitename/modx/core/xpdo/xpdo.class.php : 331) SQLSTATE[28000] [1045] Access denied for user ’db355393303’@’localhost’ (using password: YES)
[2011-01-25 10:54:56] (ERROR in xPDO::connect @ /homepages/27/d204533922/htdocs/sitename/modx/core/xpdo/xpdo.class.php : 331) SQLSTATE[28000] [1045] Access denied for user ’db355393303’@’localhost’ (using password: YES)
Just wondering if anyone has any clue what I might still be doing wrong? Stupid 1&1!
Thanks
-
MODX Staff
- 12,272 Posts
Hosts with issues will suck the life out of you.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
I see one issue rightaway 1and1 mysql usernames start with dbo not db
username: dbo355393303
db name: db355393303
Side note: If you are on a shared platform your hostname probably isn’t localhost, it will be something like db####.perfora.net
Hope that helps.
neilp123, you still having issues?
I use 1and1 and have two Evo sites and one Revo working with them.
I had issues to, but it turned out to be naming issues like lutenegger says above.
Are you having issues with the install ans setup?
BG66