We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36926
    • 701 Posts
    Hi,

    Trying to install revo, all the steps go ok until I click the install button. I’ve tried the steps mentioned in the docs about if you get a blank page:

    1. Make sure the directories "/[root]", "/core/packages","/core/cache", and "/core/export" are writable. (root will be the actual directory you are installing to.)
    2. Make sure your php.ini setting sets memory_limit to 128M, and max_execution_time to 120
    3. Create a blank file "/core/config/config.inc.php" and make it writable. DO NOT COPY config.inc.tpl! Just make it a blank file!

    But still can’t get past the blank page. I’m on shared hosting but didn’t have any problems when I install a revo release back in march.

    Ok this is config, not sure exactly what you need:


    Web Server:
    PHP Version 5.2.13
    System Linux web135.extendcp.co.uk 2.6.9-89.0.26.ELsmp #1 SMP Sun May 30 09:31:52 EDT 2010 i686
    Linux
    Server API: CGI
    MySQL 5.1.48

    PDO Driver for MySQL, client library version 5.1.48


    PHP CORE
    allow_call_time_pass_reference Off Off
    allow_url_fopen On On
    allow_url_include Off Off
    always_populate_raw_post_data Off Off
    arg_separator.input & &
    arg_separator.output & &
    asp_tags Off Off
    auto_append_file no value no value
    auto_globals_jit On On
    auto_prepend_file no value no value
    browscap no value no value
    default_charset no value no value
    default_mimetype text/html text/html
    define_syslog_variables Off Off
    disable_classes no value no value
    disable_functions no value no value
    display_errors Off Off
    display_startup_errors Off Off
    doc_root no value no value
    docref_ext no value no value
    docref_root no value no value
    enable_dl On On
    error_append_string no value no value
    error_log no value no value
    error_prepend_string no value no value
    error_reporting 6135 6135
    expose_php On On
    extension_dir /usr/lib/php5/ /usr/lib/php5/
    file_uploads On On
    highlight.bg #FFFFFF #FFFFFF
    highlight.comment #FF8000 #FF8000
    highlight.default #0000BB #0000BB
    highlight.html #000000 #000000
    highlight.keyword #007700 #007700
    highlight.string #DD0000 #DD0000
    html_errors On On
    ignore_repeated_errors Off Off
    ignore_repeated_source Off Off
    ignore_user_abort Off Off
    implicit_flush Off Off
    include_path .:/usr/share/pear5 .:/usr/share/pear5
    log_errors On On
    log_errors_max_len 1024 1024
    magic_quotes_gpc Off Off
    magic_quotes_runtime Off Off
    magic_quotes_sybase Off Off
    mail.force_extra_parameters no value no value
    max_execution_time 120 120
    max_file_uploads 20 20
    max_input_nesting_level 64 64
    max_input_time 60 60
    memory_limit 128M 128M
    open_basedir no value no value
    output_buffering 4096 4096
    output_handler no value no value
    post_max_size 8M 8M
    precision 14 14
    realpath_cache_size 16K 16K
    realpath_cache_ttl 120 120
    register_argc_argv Off Off
    register_globals Off Off
    register_long_arrays Off Off
    report_memleaks On On
    report_zend_debug On On
    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir no value no value
    sendmail_from no value no value
    sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
    serialize_precision 100 100
    short_open_tag On On
    SMTP localhost localhost
    smtp_port 25 25
    sql.safe_mode Off Off
    track_errors Off Off
    unserialize_callback_func no value no value
    upload_max_filesize 2M 2M
    upload_tmp_dir no value no value
    user_dir no value no value
    variables_order GPCS GPCS
    xmlrpc_error_number 0 0
    xmlrpc_errors Off Off
    y2k_compliance On On
    zend.ze1_compatibility_mode Off Off

    Thanks

    Ben
      • 28215
      • 4,149 Posts
      Do you have pdo_mysql enabled?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 36926
        • 701 Posts
        Quote from: splittingred at Aug 04, 2010, 04:53 PM

        Do you have pdo_mysql enabled?

        Not 100% sure but looks like it, in my phpinfo file i’ve got:

        PDO
        PDO support enabled
        PDO drivers sqlite, sqlite2, mysql

          • 28215
          • 4,149 Posts
          - Do you have mod_security on?
          - Are you running eAccelerator, APC, winCache or xCache?
          - Are there any install logs in core/cache/logs/ ?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 36926
            • 701 Posts
            Quote from: splittingred at Aug 04, 2010, 05:01 PM

            - Do you have mod_security on?
            - Are you running eAccelerator, APC, winCache or xCache?
            - Are there any install logs in core/cache/logs/ ?


            Hey thanks for the reply.

            How do i check point 1 and 2?

            There’s no logs directory been created.
              • 36926
              • 701 Posts
              Quote from: splittingred at Aug 04, 2010, 05:01 PM

              - Do you have mod_security on?
              - Are you running eAccelerator, APC, winCache or xCache?
              - Are there any install logs in core/cache/logs/ ?
              Ok contacted provider and have got this response


              mod_security is enabled on our servers by default. However, the caching systems you mention above are not.

              We do have the zend_optimiser installed and enabled though.

              Does this help?
                • 28215
                • 4,149 Posts
                Try disabling those and see if it works.
                  shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                  • 36926
                  • 701 Posts
                  Quote from: splittingred at Aug 04, 2010, 10:10 PM

                  Try disabling those and see if it works.

                  Ok the mod_security was actually already disablled.

                  I’ve now turned off zend_optimiser and still blank page.

                  It’s looking like it’s i may have to stick with EVO for time being and get left behind in the revolution sad

                  Has anyone successfully installed revo on a heartinternet reseller hosting account?
                    • 36926
                    • 701 Posts
                    smiley laugh grin grin grin grin Ok it’s working but not sure exactly what solved it. But i’ll list what i’ve done differently.

                    I re uploaded revo but this time it was on a different domain within a folder. It’s the same shared hosting so that shouldn’t make a differenc and can’t see it being within a folder making a difference either.

                    I uploaded using a different FTP as using a different comp (windows not OS this time). Thinking maybe not all files uploaded.

                    I also made sure the I had a php.ini file already uploaded with memory_limit set to 128M, and max_execution_time set to 120 before i vistied the setup folder.

                    Now as said not sure what made the difference but I think maybe not everything FTPing up ok.

                    I’m going to now try again on the other domain, hopefully i’ll have success.

                    Ben