We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6657
    • 4 Posts
    Hi,

    I was wondering if anyone has come across this issue before. I’ve gone through the setup, done the database logins etc, added a new user, done the permissions on the directories (all was fine), and then on the next screen I just get :

    Fatal error: Call to a member function install() on a non-object in /home/modx/public_html/setup/includes/modinstall.class.php on line 358

    And that’s it, nothing else.

    I’m attempting to install the standard version of Revolution on a box running CENTOS 5.5 i686 standard.

    If anyone has any suggestions to get it working please fire away, I’d be delighted to get this up and running.

    Thanks, Dave
      • 28215
      • 4,149 Posts
      From: "BEFORE YOU POST HERE: READ THIS (ESPECIALLY YOU BUG REPORTERS)":


      3. If you’re posting about a bug, please state all of your Environment information in your post: Server OS, Server Version, PHP Version, MySQL Version (client and server), is pdo_mysql installed, your Browser type and version, and any other environment data we should know.

        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 6657
        • 4 Posts
        All the info I have is..

        Server OS : CENTOS
        Server Version : 5.5 i686 standard
        PHP Version : 5.2.9
        MySQL Version (client and server) : 5.0.91
        pdo_mysql installed : yes
        PDO Driver for MySQL, client library version : 5.0.91
        Browser type and version : firefox, version 3.6.4

        There’s nothing else I can think of, let me know if there is anything else I need to find out.

        cheers, Dave
          • 28215
          • 4,149 Posts
          Do you have eAccelerator, APC, xCache or winCache running? Might be an issue with those.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 6657
            • 4 Posts
            Hi,

            I’ve just been through the server config and can’t find anything you mentioned enabled. eAccelator is the only one listed but thats disabled.

            Cheers, Dave
              • 6657
              • 4 Posts
              Nice one.

              Seeya.
                • 34017
                • 898 Posts
                Sorry you hadnt heard back on this one. I had the same problem.

                The problem line is:
                <?php
                $package = xPDOTransport :: retrieve($this->xpdo, $packageDirectory . 'core.transport.zip', $packageDirectory, $packageState);
                


                The problem is this is returning ’null’. There’s no error checking to see if $package is actually a class. So we get the error

                Fatal error: Call to a member function install() on a non-object in /setup/includes/modinstall.class.php on line 358.

                Solution:
                You probably need to setup a config file and run the build process described here: http://rtfm.modx.com/display/revolution20/Git+Installation#GitInstallation-RuntheBuild

                After I ran the build file, I went upgrade the install, and it failed. So I
                1. deleted the database
                2. Ran brand new install

                and it worked.
                  Chuck the Trukk
                  ProWebscape.com :: Nashville-WebDesign.com
                  - - - - - - - -
                  What are TV's? Here's some info below.
                  http://modxcms.com/forums/index.php/topic,21081.msg159009.html#msg1590091
                  http://modxcms.com/forums/index.php/topic,14957.msg97008.html#msg97008
                  • 3749
                  • 24,544 Posts
                  Could you post that bug (improvement?) on Jira to make sure it doesn’t fall through the cracks?
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 22668
                    • 718 Posts
                    Also error happens when you remove core.transport.zip from core/packages directory. (even if you manually unpack this archive)
                    Thanks Chuck.