We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 13373
    • 70 Posts
    Hi there,

    I’m having trouble with the Resources Web Tree, as it keeps disappearing when using the Manager. If I clear the Site Cache, it returns, only to disappear when I edit a resource.

    Also, clicking the Refresh icon sometimes works, sometimes not.

    I’ve also cleared my browser’s cache (Google Chrome) as well!

    When viewing in IE8, same thing happens, and I get the following javascript error:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET CLR 1.1.4322; .NET4.0C)
    Timestamp: Wed, 4 Aug 2010 01:05:52 UTC


    Message: Syntax error
    Line: 7
    Char: 102830
    Code: 0
    URI: http://www.mydomain.com/manager/assets/ext3/ext-all.js

    I’m using the latest Rev version.

    Not sure what to do here, so some help would be most appreciated smiley
      • 28215
      • 4,149 Posts
      - PHP version?
      - MySQL client/server version?
      - Traditional or advanced distribution?
      - Are you using any opcode caching, such as eAccelerator, xCache, WinCache, APC, etc? (Please check)
      - mod_security enabled?
      - Any errors in core/cache/logs/error.log?
      - Anything else we should possibly know?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 13373
        • 70 Posts
        - PHP version?

        5.3.3

        - MySQL client/server version?

        4.1.22-standard

        - Traditional or advanced distribution?

        Traditional

        - Are you using any opcode caching, such as eAccelerator, xCache, WinCache, APC, etc? (Please check)

        eAccelerator is switched off using a .htaccess file

        - mod_security enabled?

        Doesn’t show in PHP info?

        - Any errors in core/cache/logs/error.log?

        A bunch of errors like:

        [2010-08-04 11:50:02] (ERROR @ /home/blah/public_html/core/xpdo/om/xpdoobject.class.php : 1858) PHP warning: in_array() expects parameter 2 to be array, null given
        [2010-08-04 11:51:09] (ERROR @ /home/blah/public_html/core/xpdo/om/xpdoobject.class.php : 1858) PHP warning: in_array() expects parameter 2 to be array, null given
        [2010-08-04 11:51:09] (ERROR @ /home/blah/public_html/core/xpdo/om/xpdoobject.class.php : 1858) PHP warning: in_array() expects parameter 2 to be array, null given
        [2010-08-04 11:51:15] (ERROR @ /home/blah/public_html/core/xpdo/om/xpdoobject.class.php : 1858) PHP warning: in_array() expects parameter 2 to be array, null given

        Edit:

        Getting this error as well:

        [2010-08-04 12:18:32] (ERROR @ /home/blah/public_html/core/xpdo/xpdo.class.php : 1668) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected
          • 13373
          • 70 Posts
          Can anyone point me in the right direction? All help greatly appreciated smiley

          I’m still getting errors like this in my log:

          [2010-08-05 12:40:04] (ERROR @ /home/blah/public_html/core/xpdo/xpdo.class.php : 1668) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected
          [2010-08-05 12:49:53] (ERROR @ /home/blah/public_html/core/xpdo/om/xpdoobject.class.php : 1858) PHP warning: in_array() expects parameter 2 to be array, null given

          I also tried setting up a brand new account, and installed the sample site successfully.

          The error log on the new account then shows:

          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not copy /home/modx/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not copy /home/modx/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not copy /home/modx/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not install files from /home/modx/public_html/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to
          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not install files from /home/modx/public_html/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to
          [2010-08-05 13:20:15] (ERROR @ /setup/index.php) Could not install files from /home/modx/public_html/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to

          Hopefully, seeing these errors might help shed some light on my problem!!!

          Another (possibly related?) issue is that my documents listed by FileLister (eg pdfs) are simply not downloading, either. Nothing’s happening when they’re clicked.

          Edit - FileLister problem fixed smiley Turns out it’s crucial that you have the forwardslash / at the end of the file path wink

          Thanks for your time and assistance smiley
            • 13373
            • 70 Posts
            I think I’ve been able to solve this issue smiley

            Turns out that as I had PHP 5.3.x on my server, it has compatibility issues with Zend Optimizer.

            Once it was rolled back to 5.2.9, Zend Optimizer started working again (on another unrelated site), AND the Resource Tree is working properly!

            Perhaps there is some Zend Guarded code within the Ext.js stuff, and this is what’s causing a lot of dramas??

            I just wanted to post my findings, so it can help others who are having similar issues...
              • 19388
              • 297 Posts
              I have the same problem, the tree appear and dissapear misteriously:
              PHP Version 5.2.14
              MySQL 5.0.91
              Traditional
              mod_security enabled
              Zend Optimizer v3.3.9

              Errors:
              [2010-09-27 04:40:27] (ERROR @ /home/netfacto/public_html/aeromedica/core/xpdo/xpdo.class.php : 1668) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected