We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3688
    • 43 Posts
    Hi,

    I just upgraded from RC2 to 2.0.0-pl.
    The manager is working fine, but the site itself only shows a blank page. Looking into the php-error-log I assume this is some cache-issue:
    [26-Jul-2010 00:06:24] PHP Fatal error:  Class 'BreadCrumbs' not found in /Users/bnetz/Sites/modx-info/core/cache/elements/modsnippet/3.include.cache.php on line 40
    [26-Jul-2010 00:06:27] PHP Fatal error:  Class 'BreadCrumbs' not found in /Users/bnetz/Sites/modx-info/core/cache/elements/modsnippet/3.include.cache.php on line 40


    I cleaned the cache with the tool in the manager and flushed permissions etc., but this did not help. Has anybody any idea?

    Thanks in advance!
      • 28215
      • 4,149 Posts
      Try reinstalling Breadcrumbs?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 3688
        • 43 Posts
        hi splittingred,

        thanks for your answer!

        I would like to, but I get some errors with every option (preserve, uninstall, restore):
        Finding package with signature: breadcrumbs-1.1-rc1
        Could not open file for reading: breadcrumbs-1.1-rc1.transport.zip?revolution_version=Revolution-2.0.0-pl
        MODx could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
        Could not transfer package breadcrumbs-1.1-rc1.transport.zip to /Users/bnetz/Sites/modx-info/core/packages/.
        Package found. Preparing to uninstall.
        Could not open file for reading: breadcrumbs-1.1-rc1.transport.zip?revolution_version=Revolution-2.0.0-pl
        MODx could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
        Could not transfer package breadcrumbs-1.1-rc1.transport.zip to /Users/bnetz/Sites/modx-info/core/packages/.
        Could not load transport package.


        See also screenshot attached.

        Is there any possibility to solve this?
          • 3749
          • 24,544 Posts
          It looks like you need to enable cURL (or have the host do it for you).
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 3688
            • 43 Posts
            I am running on a local server here (MAMP@Mac). It seems that cURL is enabled. I ran a test-script from the web
            <?php 
            echo '<pre>'; 
            var_dump(curl_version()); 
            echo '</pre>'; 
            ?>


            and I get:
            array(9) {
              ["version_number"]=>
              int(463872)
              ["age"]=>
              int(3)
              ["features"]=>
              int(1565)
              ["ssl_version_number"]=>
              int(0)
              ["version"]=>
              string(6) "7.20.0"
              ["host"]=>
              string(23) "i386-apple-darwin8.11.1"
              ["ssl_version"]=>
              string(14) "OpenSSL/0.9.7l"
              ["libz_version"]=>
              string(5) "1.2.3"
              ["protocols"]=>
              array(16) {
                [0]=>
                string(4) "dict"
                [1]=>
                string(4) "file"
                [2]=>
                string(3) "ftp"
                [3]=>
                string(4) "ftps"
                [4]=>
                string(4) "http"
                [5]=>
                string(5) "https"
                [6]=>
                string(4) "imap"
                [7]=>
                string(5) "imaps"
                [8]=>
                string(4) "ldap"
                [9]=>
                string(4) "pop3"
                [10]=>
                string(5) "pop3s"
                [11]=>
                string(4) "rtsp"
                [12]=>
                string(4) "smtp"
                [13]=>
                string(5) "smtps"
                [14]=>
                string(6) "telnet"
                [15]=>
                string(4) "tftp"
              }
            }


            don’t know if this is right, but it seems so smiley

            The rc2 did run very well and I could install and uninstall packages ... perhaps it is a caching issue?
              • 3749
              • 24,544 Posts
              Sorry, I didn’t look closely enough at your error message.

              It’s my understanding that cURL is supposed to bypass problems caused by allow_url_fopen=off, so maybe it’s a problem with the configuration of cURL or possibly ownership of the file(s) in question.

              I’m sure someone else can give a better answer.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 3688
                • 43 Posts
                The problem was that i replaced the core-folder from my old installation with the core-folder of the new installation completely. Because this is (for me and my bad English) a source of misunderstanding I made a suggestion in the Documentation-forum (here).

                Anyway, thanks for taking your eyes on my problems!

                (my case closed)