We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22851
    • 805 Posts
    First of all, congratulations on MODx Revolution 2.0. I’ve just tried to do a fresh install using the advanced download, but failed. (Ubuntu server, PHP 5.2.6-3, mysql 5.0.75.)

    On the installation summary page the installer checks to see if various folders are writable. The installer claims that my root web folder is not writable:

    Checking if /something/or/other/ directory is writable: Failed!

    However, I have checked, and it definitely IS writeable by the web server and belongs to the correct user and group etc. On further investigation I think there may be a bug in the installer, in the method [tt]_checkAdvPaths[/tt] within setup/includes/checks/modinstalltestadvanced.class.php.

    The code in question is
            /* web_path */
            $this->results['context_web_writable']['msg'] = '<p>'.sprintf($this->install->lexicon['test\
    _directory_writable'],$this->install->settings->get('context_web_path'));
            $webDir = dirname($this->install->settings->get('context_web_path'));
            if (!$this->is_writable2($webDir)) {
                $this->results['context_web_writable']['msg'] .= '<span class="notok">'.$this->install-\
    >lexicon['failed'].'</span></p>';
                $this->results['context_web_writable']['class'] = 'testFailed';
            } else {
                $this->results['context_web_writable']['msg'] .= '<span class="ok">'.$this->install->le\
    xicon['ok'].'</span></p>';
                $this->results['context_web_writable']['class'] = 'testPassed';
            }
    


    Note that the first line outputs the directory [tt]$this->install->settings->get(’context_web_path’)[/tt] to screen. However, the second defines the web directory as [tt]dirname($this->install->settings->get(’context_web_path’))[/tt]. I have checked and this is popping the final folder off the end of the web path, so the actual directory that’s being checked is one up from the web root, which in my case is not writable.

    The same thing seems to be happening for the other directories in this method. I’m not sure if the cause of the problem is a missing trailing slash on the web path or if the dirname is not required. I tried modifying my method to define

    [tt]$webDir = $this->install->settings->get(’context_web_path’);[/tt]

    but when I submitted the next page was blank. That could be a different problem. Not sure.

    Admittedly, I haven’t done much investigation to check whether this bug has already been reported elsewhere, so sorry if it repeats an existing report.
      YAMS: Yet Another Multilingual Solution for MODx
      YAMS Forums | Latest: YAMS 1.1.9 | YAMS Documentation
      Please consider donating if you appreciate the time and effort spent developing and supporting YAMS.
      • 22851
      • 805 Posts
      Regarding the blank page, here’s some output from my error log (with obfuscated private info). Note the fatal error:

      [Sat Jul 24 11:14:18 2010] [error] [client ##.###.###.###] PHP Warning: PDO::query() [<a href=’pdo.query’>pdo.query</a>]: SQLSTATE[42S02]: Base table or view not found: 1146 Table ’mytable.prefix_transport_providers’ doesn’t exist in /mypath/core/xpdo/xpdo.class.php on line 1796, referer: http://mysite/setup/index.php?action=summary
      [Sat Jul 24 11:14:18 2010] [error] [client ##.###.###.###] PHP Warning: ZipArchive::extractTo() [<a href=’ziparchive.extractto’>ziparchive.extractto</a>]: Invalid or unitialized Zip object in /mypath/core/xpdo/compression/xpdozip.class.php on line 142, referer: http://mysite/setup/index.php?action=summary
      [Sat Jul 24 11:14:18 2010] [error] [client ##.###.###.###] PHP Warning: ZipArchive::close() [<a href=’ziparchive.close’>ziparchive.close</a>]: Invalid or unitialized Zip object in /mypath/core/xpdo/compression/xpdozip.class.php on line 153, referer: http://mysite/setup/index.php?action=summary
      [Sat Jul 24 11:14:18 2010] [error] [client ##.###.###.###] PHP Fatal error: Call to a member function install() on a non-object in /mypath/setup/includes/modinstall.class.php on line 358, referer: http://mysite/setup/index.php?action=summary
        YAMS: Yet Another Multilingual Solution for MODx
        YAMS Forums | Latest: YAMS 1.1.9 | YAMS Documentation
        Please consider donating if you appreciate the time and effort spent developing and supporting YAMS.