We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28554
    • 201 Posts
    Hi Guys,

    I’ve started moving a site from staging to dev, and am running into some weird problems. The manager won’t even show login anymore... I’ve contacted my host, and they sent me the error-log for the server, which included this:

    [Tue Jul 13 11:59:16 2010] [error] [client 83.85.21.232] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/home/sites/site17724/web/website/core/model/phpthumb/phpThumb.class.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/sites/site17724/web/website/core/model/modx/processors/system/phpthumb.php on line 24, referer: http://www.akto.nl/website/manager/index.php?a=30&id=39
    


    Any thoughts?
      • 28215
      • 4,149 Posts
      Might be a capitalization issue (this was fixed in SVN). Try applying this patch:

      http://svn.modxcms.com/crucible/changelog/modx/?cs=7099
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 28554
        • 201 Posts
        Quote from: splittingred at Jul 13, 2010, 08:39 AM

        Might be a capitalization issue (this was fixed in SVN). Try applying this patch:

        http://svn.modxcms.com/crucible/changelog/modx/?cs=7099

        Yeah I figured that one out, so I changed it, and also tried copying phpthumb.class.php and renaming the copy to phpThumb.class.php, both didn’t work... Is there some way to force MODx to clear it’s entire cache without loggin in to the manager?
          • 28215
          • 4,149 Posts
          Empty the core/cache/ directory.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 28554
            • 201 Posts
            That didn’t do the trick either. I’m really stumped at the moment...
              • 28215
              • 4,149 Posts
              Did you run setup in upgrade mode after moving the site?
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 28554
                • 201 Posts
                Yeah I did... The problem was already there before I moved though, this just sped up my decision to move it into the rootfolder. I can’t even login with Provisioner from an installation on my own dev-server...
                  • 28554
                  • 201 Posts
                  Ok, so I fixed it. Turns out not a single path in config.inc.php was rewritten after the upgrade-install... Still very weird situation all in all...