We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 1778
    • 659 Posts
    Hi all

    I have this error in my error.log... But no more precision...
    [2010-07-06 11:09:38] (ERROR @ /index.php) Error caching resource 
    


    It doesn’t seem to have any impact on the site but I would like to understand what is this error... and if I can do anything to correct it...

    BTW can this error have any impact I have not seen yet ? (ie: in execution of snippets, or other...)

    Thanks
    Cheers
      • 28215
      • 4,149 Posts
      Yes, it can; are you running any opcode caching, such as eAccelerator, xCache, etc?

      Please report your PHP/MySQL/Apache versions, as well as any other environment variables we should know.

      (This might also be causing your quip issue.)

        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 1778
        • 659 Posts
        I use none opcode caching (no eAccelarator, no xCache... nothing like that)

        The error seems "sporadic"
        First time of the day I connect to the manager via mysite.fr/manager => error appears, I clear log.

        The second time error not happens... Nothing in log...

        I tried to connect as admin on front-end, I can log in with no problem => No error in the log.
        Then I disconnect from Front-end. Re-connect via Manager => no error in log...

        Configuration

        Linux Debian Lenny
        Apache 2.2.11
        PHP 5.3.2-0 dotdeb.2
        MySQL 5.1.48
        MySQL Cient API : mysqlnd 5.0.7-dev - 091210 - $Revision: 294543 $

        Revo RC3#rev7064

        [EDIT]
        Error seems appear only when the site_status is "NO"..., it totally diseappears if the site is online...

        Cheers
          • 22303 MODX Staff
          • 10,725 Posts
          Have you specified a site_unavailable_page?
            • 1778
            • 659 Posts
            No I had not, if I hit http://mysite.fr it returns the standard message "site temporarily unavailable"...Is it absolutely required? The default settings are not enough for this ?

            BTW I did a brand new fresh install this morning (new checkout from svn, new database, new fresh install from scratch) and all is fine... No error in the log, my troubles with Quip are gone away, etc...

            I suppose there was a kind of corrupted file or table during an update from svn, that has not displayed any error, and corrupted one or many files/tables/data/ (check all that applies)... but I have absolutely no idea of what or when, and no idea of how to detect it and "undo" or "uncorrupt" it...

            So the solution of totally new fresh install was the one I chosen just to be sure... (not a config problem, or something else with my local install or my remote server...)

            Cheers
              • 22303 MODX Staff
              • 10,725 Posts
              It’s a harmless error; since it’s not a real Resource object, it can’t be cached because it doesn’t have a valid id. wink

              Can you enter a ticket anyway so we address it a don’t fill up the logs when folks set their site to offline?
                • 1778
                • 659 Posts
                Done in Jira Issue MODX-2114.
                Cheers