We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 13373
    • 70 Posts
    Hi there,

    I’ve installed Revo 2 on my development server, and whilst I can log in to the Manager, I’m unable to download any packages - it won’t even show the default modx provider or allow me to enter it. I’m also not able to add any users, and again, it won’t even show the root admin user, which I know has to be there!

    Not sure what info you need, but I’m using PHP 5.2.13, MySQL 5.0.90, Apache 2.2.15.

    Hope someone can help!

    Cheers
    Jacob
      • 28215
      • 4,149 Posts
      Quote from: TasDeveloper at Jun 01, 2010, 08:54 PM

      Hi there,

      I’ve installed Revo 2 on my development server, and whilst I can log in to the Manager, I’m unable to download any packages - it won’t even show the default modx provider or allow me to enter it. I’m also not able to add any users, and again, it won’t even show the root admin user, which I know has to be there!

      Not sure what info you need, but I’m using PHP 5.2.13, MySQL 5.0.90, Apache 2.2.15.

      1. Are you running any accelerators/caching systems, such as eAccelerator, APC, xCache, etc?
      2. What does it do when you try to "enter" the Package Management screen? Can you describe in detail the process you’re doing?
      3. Did you mess around with any of the Access Policies?
      4. Do you have any relevant errors in core/cache/logs/error.log?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 13373
        • 70 Posts
        1. Are you running any accelerators/caching systems, such as eAccelerator, APC, xCache, etc?

        It does look like eAccelerator support is enabled, version 0.9.6.

        2. What does it do when you try to "enter" the Package Management screen? Can you describe in detail the process you’re doing?

        Clicking on System -> Package Management, click on Providers and it just says there’s no data to display. It also won’t allow me to add a new Provider.

        Says No Data in the user area too.

        3. Did you mess around with any of the Access Policies?

        Nope, haven’t touched anything in there smiley

        4. Do you have any relevant errors in core/cache/logs/error.log?

        Getting this:

        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/cb6735d74324be818cbc168c34fee488/0/ to index.php
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/cb6735d74324be818cbc168c34fee488/1/ to ht.access
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/416c2e5105292945e37fc3fdd8099215/0/ to assets
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/416c2e5105292945e37fc3fdd8099215/1/ to controllers
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/416c2e5105292945e37fc3fdd8099215/2/ to templates
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/416c2e5105292945e37fc3fdd8099215/3/ to ht.access
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not copy /home/mydomain/public_html/core/packages/core/modContext/416c2e5105292945e37fc3fdd8099215/4/ to index.php
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/e1a99604dbe3574c67514fb6ee00a822/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/37716d61897c4e3b27eeeea6228fc421/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/20d024f77c7a330017db87ec029a7400/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/db5fe1e0bcf62416c0be9a49e5dc6d81/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/d9ca0463ea831c92ede1051ab7cfc625/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/67fca7fc2fd1d41b99372850903de700/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/87a2082dd4ea568d58eae1fcd1bb88ec/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/874c323e74f2fa87efba0b8407b290bf/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/6236add07797340510d138abafa998ff/ to
        [2010-06-02 11:18:44] (ERROR @ /setup/index.php) Could not install files from /home/mydomain/public_html/core/packages/core/xPDOFileVehicle/269f4f43c713ad772b36298bb6af3e9f/ to
        [2010-06-02 11:21:50] (ERROR @ /connectors/workspace/providers.php) Could not connect to provider at: test.com

        (I’ve changed the account username to mydomain, to protect the innocent smiley )
          • 13373
          • 70 Posts
          I’m going to go in and turn eAccelerator off in the php.ini, and run the setup files again, and see how that goes.

          Thanks for the point in the right direction - I didn’t even know eAccelerator was on, for the server!
            • 13373
            • 70 Posts
            Thank you!!!

            I turned it off with a .htaccess file, re-ran the setup and voila smiley

            Maybe this could be another check process within the installer?

            Cheers, and thanks again.

            Jacob
              • 28215
              • 4,149 Posts
              Quote from: TasDeveloper at Jun 03, 2010, 02:35 AM

              Maybe this could be another check process within the installer?

              We would, except it works in some environments, and not in others, and there’s no rhyme or reason to which.

              What I’m guessing is either a misconfiguration at the implementation level for the servers having problems, or that there’s a PHP version that causes problems with it.
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: splittingred at Jun 03, 2010, 07:51 AM

                Quote from: TasDeveloper at Jun 03, 2010, 02:35 AM

                Maybe this could be another check process within the installer?

                We would, except it works in some environments, and not in others, and there’s no rhyme or reason to which.

                What I’m guessing is either a misconfiguration at the implementation level for the servers having problems, or that there’s a PHP version that causes problems with it.
                Right, there are often specific versions of eAccelerator that work with specific versions of PHP and if you mismatch them, you can run into bugs like this.

                FWIW, the particular bug that seems to be the most common occurs when there are multiple classes specified in a single file. This occurs in several instances in xPDO/MODx and certain configurations seem to keep the main class from the file in memory but seem to lose the definition of any additional classes defined in those files.