We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 1778
    • 659 Posts
    Hi all !

    I just updated Revo to rev6781 from SVN. And I have some problems with Lexicon...

    Configuration :
    Windows7
    Wamp 2.0.i
    PHP 5.3.1
    Apache 2.2.11
    MySQL 5.1.41
    MySQLClient mysqlnd 5.0.5-dev - 081106 - $Revision: 289630 $
    All privileges and grant on the DB...


    The Modx Error.log show theses errors...

    [2010-05-14 09:34:00] (ERROR @ /revo/setup/index.php) Error 42S02 executing statement:
    Array
    (
    [0] => 42S02
    [1] => 1146
    [2] => Table ’revo.modx_lexicon_topics’ doesn’t exist
    )

    [2010-05-14 09:34:00] (ERROR @ /revo/setup/index.php) Error 42S02 executing statement:
    Array
    (
    [0] => 42S02
    [1] => 1146
    [2] => Table ’revo.modx_lexicon_topics’ doesn’t exist
    )

    [2010-05-14 09:34:00] (ERROR @ /revo/setup/index.php) Could not drop table modLexiconLanguage
    SQL: DROP TABLE `modx_lexicon_languages`
    ERROR: Array
    (
    [0] => 42S02
    [1] => 1051
    [2] => Unknown table ’modx_lexicon_languages’
    )

    [2010-05-14 09:34:00] (ERROR @ /revo/setup/index.php) Could not drop table modLexiconTopic
    SQL: DROP TABLE `modx_lexicon_topics`

    ERROR: Array
    (
    [0] => 42S02
    [1] => 1051
    )

    Is there anything I can do to resolve that issue ? or is this a bug ?
    Thanks
      • 22303 MODX Staff
      • 10,725 Posts
      Did you run the rebuild and upgrade? Some significant Lexicon changes were made in a recent commit, and those tables are no longer used.
        • 1778
        • 659 Posts
        Hello,

        of course I ran rebuild and setup... twice, 3 times... Same result...

        cheers
          • 28215
          • 4,149 Posts
          Ignore the drop table errors - they’re looking for tables that have already been dropped (because you already ran setup).

          If those tables still exist in your DB, then your DB user doesnt have permissions to drop tables. If they dont, you’re fine.

          Either way, tables there or not, should not affect your Revo performance.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 1778
            • 659 Posts
            ok but... How can I now import or export a lexicon ?
            I have no button like "import lexicon" or "export lexicon" at the bottom of Lexicon Management Page...
            Did I miss something ?
            Cheers
              • 22303 MODX Staff
              • 10,725 Posts
              Quote from: anso at May 14, 2010, 08:22 AM

              ok but... How can I now import or export a lexicon ?
              I have no button like "import lexicon" or "export lexicon" at the bottom of Lexicon Management Page...
              Did I miss something ?
              Yes, only overridden entries are in the database now; otherwise they are loaded directly from file. No need to import or export anymore.
                • 1778
                • 659 Posts
                Great ! Is this feature documented somewhere ?
                Cheers
                  • 28215
                  • 4,149 Posts
                  Quote from: anso at May 14, 2010, 08:41 AM

                  Great ! Is this feature documented somewhere ?

                  Not in official docs yet - but here: http://modxcms.com/forums/index.php/topic,49077.0.html
                    shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com