Something had to change; perhaps you edited permissions in some way that now prevents access to the manager, or your hosting server was upgraded, or any number of other possibilities. It just doesn’t stop working for no reason.
This morning Modx failed to log me in. The username and password are correct. I even used the ’forgot password’ button. If I use a wrong password or username I get the message "The username or password you entered is incorrect. Please check the username, re-type the password, and try again"
But when I use the correct username and password the screen refreshes and I get again my login screen.
As I know nothing has changed. Looked in the SQL database and blocked and failedlogincount are 0.