We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17207
    • 23 Posts
    Hi guys,

    I started with modx 2 days ago... I’ve been trying to install packages with no luck, I get the list of ’categories’ (on the tree on the left, but nothing on the right side, just a ’loading’ sign, and recently found out this errors in the logs:

    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: Entity: line 306: parser error : Extra content at the end of the document
    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: 0
    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: ^
    [2010-04-14 13:48:16] (ERROR @ /modx2rc1inst/connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras
    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: Entity: line 306: parser error : Extra content at the end of the document
    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: 0
    [2010-04-14 13:48:16] (ERROR @ D:\xampp\htdocs\modx2rc1inst\core\model\modx\rest\modrestclient.class.php : 168) PHP warning: simplexml_load_string() [<a href='function.simplexml-load-string'>function.simplexml-load-string</a>]: ^
    [2010-04-14 13:48:16] (ERROR @ /modx2rc1inst/connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras
    


    MODx is running in a win7 with the latest XAMPP (all requirements for modx were met).

    Do you have any idea what might be doing this?
    Thanks.
      • 28215
      • 4,149 Posts
      Enable cURL in XAMPP.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 22303 MODX Staff
        • 10,725 Posts
        MODx tries to use a pure socket solution if cURL is not available, but there is a bug in it that is adding extra junk; splittingred is suggesting enabling cURL to be able to use package management until the problem is identified and fixed.
          • 17207
          • 23 Posts
          Thanks a lot guys!!!

          DOH! embarrassed rolleyes

          Sorry for the dumb question i bet it was answered a couple million times...
          That happens when you install a package and don’t check the config files...