We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 29529
    • 34 Posts
    In a new Revo install, Site->Clear Cache loads the Console window which then hangs at: Console running . . .

    I figured it might be a permissions problem on core/cache/config.cache.php - but that’s set to 777

    Any ideas?

    Thanks!

    Terry

      • 28215
      • 4,149 Posts
      Do you get any JS errors? Does the OK button enable?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 29529
        • 34 Posts
        The OK button does not enable.

        And Reports -> Error Log simply reloads the page . . .

        Thanks!

        Terry
          • 28215
          • 4,149 Posts
          - PHP/MySQL version?
          - Browser/OS?
          - Is your core/cache/ directory writable?
          - Any relevant errors in core/cache/logs/error.log?
          - eAccelerator or APC enabled?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 29529
            • 34 Posts
            PHP 5.2.11

            MySQL 5.0.45

            core/cache is writable

            core/cache/logs/error.log has multiple copies of this line:
            [2010-04-14 12:01:14] (ERROR @ /home/dev/html/modx-2.0/core/xpdo/xpdo.class.php : 1610) PHP warning: json_encode() [<a href=’function.json-encode’>function.json-encode</a>]: recursion detected

            eAccelerator Enabled

            Don’t know about APC . . .

            Thanks!

            Terry
              • 28215
              • 4,149 Posts
              Does the error still occur if you turn eAccelerator off?
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 29529
                • 34 Posts
                Well, eAccelerator is enabled but Caching Enabled and Optimizer Enabled are both False and Cache Scripts and Removed Scripts and Cached Keys are all 0 . . .

                Will that do, or do I need to Disable it altogether?

                And MODx still won’t cache . . .

                Thanks!

                Terry
                  • 29529
                  • 34 Posts
                  I tried deleting

                  /core/cache/config.cache.php

                  which apparently forces MODx to create a new one.

                  Permissions on the new one are set to 644.

                  Is that correct?

                  Thanks!

                  Terry
                    • 22303 MODX Staff
                    • 10,725 Posts
                    You do not need to change permissions of any files other than the ones directed in installation instructions. If MODx (IOW the user executing the PHP process) can write to the core/cache/ directory, all is good. If you want them to be written with different permissions, edit the new_folder_permissions and new_file_permissions system settings. This might be useful if you are on a shared hosting service that does not run suexec; in these cases if you do not set them to 0777/0666, you will not have access to delete them. But it appears you do have permission to delete them, so shouldn’t be an issue for your environment.
                      • 29529
                      • 34 Posts
                      I began to have other problems - pages wouldn’t Save - so I decided to re-install.

                      However, install is now failing . . .

                      The second Setup screen offers me the opportunity to change the MODx configuration key - which i hadn’t noticed before. (I leave it with the offered config . . .)

                      The third allows me to select Upgrade Existing Install - which I do. (But the other selections product the same results.)

                      The fourth screen - Connection Information - fills in the db info but the Test database link and the Create or test selection do nothing. And the Connection character set drop down is empty.

                      If I click Next anyway I get the Installation Summary which says everything is fine - including the memory limit set to 128M

                      But clicking Install produces only a blank screen . . .

                      I seem to have gotten way off track here.

                      Any suggestions?

                      Thanks!

                      Terry