We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15747
    • 7 Posts
    Dear Colleagues:

    I updated my install to RC 2.0. All seemed well until I tried to edit a resource. The resource page loads, the content loads, and all looks good for a split second, but then page goes gray, and a "Loading" notifier (with the circulating "busy" indicator) pops up and there things hang. The same thing happens if I try to create a resource. The error log has no recent entries. I apologize if this issue has been addressed. Any suggestions?
      • 22303 MODX Staff
      • 10,725 Posts
      I think you probably just have cached javascript in your browser from before the upgrade. Force refresh or manually empty your browser cache.
        • 15747
        • 7 Posts
        Clearing the caches was a good idea, but it didn’t work. I cleared both the Modx cache and my browser cache. I also tried a different browser just to be sure. I’m stuck.
          • 15747
          • 7 Posts
          Here’s a picture of my screen -- whenever I try to open a resource editor window. You can see the fields are properly populated, but the editor doesn’t properly launch.

          By the way, the way I cleared my browser cache (Firefox) just using Tools > Clear Recent History. If that’s not enough, please let me know.

          And Thank You for your help.
            • 28215
            • 4,149 Posts
            Browser? OS? PHP / MySQL Versions?
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 15747
              • 7 Posts
              Quote from: splittingred at Apr 14, 2010, 08:57 AM

              Browser? OS? PHP / MySQL Versions?

              Firefox 3.6.3 (same result in IE)
              Server runs PHP Version 5.2.10-2ubuntu6.4
              Server OS is Ubuntu (server) 9.10
              MySQL is Server version: 5.1.37-1ubuntu5.1

              Kevin
                • 28215
                • 4,149 Posts
                Ah, ubuntu. Can you verify:

                - That pdo_mysql is installed
                - Do you get any Javascript errors when loading this page?
                - Are there any relevant errors in core/cache/logs/error.log?
                  shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                  • 15747
                  • 7 Posts
                  Quote from: splittingred at Apr 14, 2010, 10:09 AM

                  Ah, ubuntu. Can you verify:

                  - That pdo_mysql is installed
                  - Do you get any Javascript errors when loading this page?
                  - Are there any relevant errors in core/cache/logs/error.log?

                  It looks like pdo_mysql was in fact not installed. I tried installing it by following the instructions here: http://www.theatons.com/ubuntu-install-php5-mysql-apache2-ssl-pdo-pdo_mysql#6. I then restarted Apache. Now, sadly, my manager page comes up blank. My client-facing pages do appear (I haven’t tested their functionality.) Any ideas what I’ve done to mess up my manager page?

                  EDIT: I grabbed the HTML from the server when I access the manager page. It looks like I’m getting the HTML for the login page, but the screen *then* goes blank (in the blink of an eye). Javascript malfunction?

                  I saw no Javascript errors when loading this page.

                  The only log errors were from TinyMCE.

                    • 22303 MODX Staff
                    • 10,725 Posts
                    If the manager was loading before, you had pdo_mysql installed, I guarantee it. It sounds more like you had installed TinyMCE and that was breaking things. Very likely. Get your environment back to where it was before you "installed" pdo_mysql and try disabling TinyMCE.
                      • 15747
                      • 7 Posts
                      Quote from: OpenGeek at Apr 14, 2010, 11:55 AM

                      If the manager was loading before, you had pdo_mysql installed, I guarantee it. It sounds more like you had installed TinyMCE and that was breaking things. Very likely. Get your environment back to where it was before you "installed" pdo_mysql and try disabling TinyMCE.

                      Oh boof. I guess pdo_mysql was installed (as part of php5_mysql?), and I didn’t need to install it using pecl.

                      So, in an attempt to get my environment back to a working state, I just used pecl to uninstall the just-installed pdo.so and pdo_mysql.so extensions and I removed "extension=pdo" and "extension=pdo_mysql" lines that I just added to php.ini.

                      Now I’ve clearly futzed up my environment. When I access my "manager" page, I now get "Fatal error: Class ’PDO’ not found in /home/modx/htdocs/core/model/modx/modx.class.php on line 336."


                      EDIT: I see that apache is logging an error, saying pdo.so is missing from the lib. Presumably my mangled "install" of PDO and PDO_MYSQL resulted in this file being deleted. I’ll find it and try to get it back in there.