We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12872
    • 68 Posts
    I have installed the modx demo site for Revolution RC1 on http://www.methodlabs.org and it looks good but some parts are still not working.

    I do not know what these error messages mean but posting them just in case it is useful to the developers.

    Lexicon errors:
    I find these kind of errors or errros such as "Language string not found" when I install packages such as quip, gallery, language builder, tinymce...
    Language string not found: "quip"
    Language string not found: "quip"
    Language string not found: "quip_desc"
    Language string not found: "quip_desc"
    An error occurred while trying to cache lexicon/en/quip/default (lexicon/language/namespace/topic)
    The file install.config.2010-03-26T22:20:10 shows the following errors
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/fb4e49f0032aa5cf6f4034e05db379c4/0/ to index.php
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/fb4e49f0032aa5cf6f4034e05db379c4/1/ to ht.access
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/0/ to assets
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/1/ to controllers
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/2/ to templates
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/3/ to ht.access
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/4/ to index.php
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/8191e3858925bcb1bd8bc897404f559a/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/0fe793562663c4ec3c0c8e1ba98d805f/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/ecc4677cc5f63dfbfa1ae201ba6dfe20/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/156b4ba936b92ea8afecb7f49ce4d914/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/5b805b7aa9438e01b4bca7bb70ebbe8d/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/9542a6c6b3252caad030c8802664fa56/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/b3786a38832bf4df3100ee77f3d5d979/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/7aed3bb8533574b5bf0e3eb8f20e4761/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/1eee6c361af3035a011697291e908b6a/ to
    [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/c64b8708afd7714fa36460e16ce9b5cc/ to
    The file error.log shows this error a number of times:
    (ERROR @ /home/xxxx/public_html/core/model/modx/rest/modrestcurlclient.class.php : 36) PHP warning: curl_setopt() [<a href=’function.curl-setopt’>function.curl-setopt</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set
    Another error found on error.log is
    [2010-03-27 09:01:07] (ERROR @ /index.php) Could not get table name for class: modAccess
    [2010-03-27 09:01:07] (ERROR @ /index.php) Error 42000 executing statement:
    Array
    (
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’AS `modAccess` WHERE `modAccess`.`principal` = 2’ at line 1
    )
    besides many errors about curl_setopt() other errors found on error.log
    [2010-03-27 18:53:35] (ERROR @ /connectors/workspace/packages.php) Could not find package manifest at /home/xxxx/public_html/core/packages/claritypack-1.0-rc1/manifest.php
    [2010-03-27 18:53:35] (ERROR @ /connectors/workspace/packages.php) Could not unpack package /home/xxxx/public_html/core/packages/claritypack-1.0-rc1.transport.zip to /home/xxxx/public_html/core/packages/. SIG: claritypack-1.0-rc1
    My installation on http://www.methodlabs.org where the demo site is currently installed is based on a server with:
    PHP Version 5.2.9
    mysql 5.0.89-community utf8




      • 28215
      • 4,149 Posts
      Quote from: indeman at Mar 27, 2010, 09:52 PM

      Lexicon errors:
      I find these kind of errors or errros such as "Language string not found" when I install packages such as quip, gallery, language builder, tinymce...

      Ignore those - if they’re in blue, you can ignore them. The errors to worry about are ones in red.


      The file install.config.2010-03-26T22:20:10 shows the following errors
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/fb4e49f0032aa5cf6f4034e05db379c4/0/ to index.php
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/fb4e49f0032aa5cf6f4034e05db379c4/1/ to ht.access
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/0/ to assets
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/1/ to controllers
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/2/ to templates
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/3/ to ht.access
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not copy /home/xxxx/public_html/core/packages/core/modContext/c09cb999d4332ce6e3cb4302c69c8218/4/ to index.php
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/8191e3858925bcb1bd8bc897404f559a/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/0fe793562663c4ec3c0c8e1ba98d805f/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/ecc4677cc5f63dfbfa1ae201ba6dfe20/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/156b4ba936b92ea8afecb7f49ce4d914/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/5b805b7aa9438e01b4bca7bb70ebbe8d/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/9542a6c6b3252caad030c8802664fa56/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/b3786a38832bf4df3100ee77f3d5d979/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/7aed3bb8533574b5bf0e3eb8f20e4761/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/1eee6c361af3035a011697291e908b6a/ to
      [2010-03-26 22:20:11] (ERROR @ /setup/index.php) Could not install files from /home/xxxx/public_html/core/packages/core/xPDOFileVehicle/c64b8708afd7714fa36460e16ce9b5cc/ to
      Sounds like your core/packages directory was not writable, or...


      The file error.log shows this error a number of times:
      (ERROR @ /home/xxxx/public_html/core/model/modx/rest/modrestcurlclient.class.php : 36) PHP warning: curl_setopt() [<a href=’function.curl-setopt’>function.curl-setopt</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set

      You’ll have to turn off safe_mode in your PHP installation. (It, imo, doesnt really make your server more safe - proper permissions and virutal directories do, but that’s my opinion). Until then, we’ll look at patching that for RC-2...can you file it as a bug here: http://bugs.modxcms.com
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 12872
        • 68 Posts
        will try all over after turning off PHP safe mode and changing permissions and file bug report with error logs.
        just checked and found that PHP safe mode was already turned off.
        Quote from: splittingred at Mar 28, 2010, 10:28 PM

        Sounds like your core/packages directory was not writable, or...
        .....
        You’ll have to turn off safe_mode in your PHP installation. (It, imo, doesnt really make your server more safe - proper permissions and virutal directories do, but that’s my opinion). Until then, we’ll look at patching that for RC-2...can you file it as a bug here: http://bugs.modxcms.com
        will try installing all over again and file bug report when i get back to a computer with a bigger screen.
          • 12872
          • 68 Posts
          I installed again afresh. directory permissions to the folders were set to 755 and files to 644
          PHP safe mode was already turned off and am getting the same errors .
          Will file a bug. Currently it apears that jira is not accessible. Will wait for that to be set right.