We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26401
    • 247 Posts
    I’ve wanted to try installing revo (MODx Revolution version 2.0.0-rc-1)
    but I’m getting an error connecting to the database (Connecting to mysql server: Could not connect to the database server. Check the connection properties and try again.)

    PHP Version 5.2.12

    MySQL
    Client API library version 5.0.90
    Client API header version 5.0.82

    my server advises me to use
    localhost:/tmp/mysql5.sock

    and with evo it works fine. is there anything I might be missing?
      • 28215
      • 4,149 Posts
      Quote from: daspoda at Mar 23, 2010, 03:31 PM

      I’ve wanted to try installing revo (MODx Revolution version 2.0.0-rc-1)
      but I’m getting an error connecting to the database (Connecting to mysql server: Could not connect to the database server. Check the connection properties and try again.)

      PHP Version 5.2.12

      MySQL
      Client API library version 5.0.90
      Client API header version 5.0.82

      my server advises me to use
      localhost:/tmp/mysql5.sock

      and with evo it works fine. is there anything I might be missing?

      Do you have PDO installed?
      Is that the correct location of the mysql socket? Did you try with just localhost?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 26401
        • 247 Posts
        yes, yes and yes smiley

        PDO drivers: mysql, sqlite, sqlite2

        those settings worked for evo install
        thanks for the quick reply

        would installing in subdomain make any difference?

        I can pm you more (sensitive) info if interested
          • 28215
          • 4,149 Posts
          Quote from: daspoda at Mar 23, 2010, 03:41 PM

          yes, yes and yes smiley

          PDO drivers: mysql, sqlite, sqlite2

          those settings worked for evo install
          thanks for the quick reply

          would installing in subdomain make any difference?

          I can pm you more (sensitive) info if interested

          I’m not exactly sure why this would happen. Can you PM or email ([email protected]) me more info? Also, your phpinfo(); ?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 28215
            • 4,149 Posts
            Just as an fyi, the problem was solved:

            When using a different port for connections, until RC-2, you’ll need to specify in this syntax:

            hostname;port=####
            


            like so:

            my.database.com;port=3307
            
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 26401
              • 247 Posts
              Thanks again for looking into this

              I would just like to clarify for anyone else having this issue, that this requires the remote connections to be enabled for mySQL