We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12872
    • 68 Posts
    It appears that Modx Revolution RC1 installs successfully on server with MySQL version 4.1.22
    RC1 failed to install on 2 different servers with MySQL version 5.0.89
    I am attaching the configuration of the servers where RC1 failed and succeded as a zip file in case someone is interested.

    However I got an error in the succesful installation such as "An error occurred while trying to cache lexicon/en/quip/default (lexicon/language/namespace/topic)" attaching the error output.

    everything else seems fine. I love the interface and more impotant my in-house web-design genius who hates using CMS has agreed to learn Revolution because we will be building a site with a lot of content.
      • 28215
      • 4,149 Posts
      When you say "failed", what do you mean? What happened?

      On the failed servers:

      You don’t have PDO installed on the first one, so that’s never going to work, as Revolution requires PDO support.

      On the second:
      1. Turn magic_quotes_gpc off
      2. Up your memory_limit to 64M

      Also, we’ll need a lot more info by what you mean by "failed" for the second server.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 22303 MODX Staff
        • 10,725 Posts
        Quote from: indeman at Mar 23, 2010, 01:46 PM

        It appears that Modx Revolution RC1 installs successfully on server with MySQL version 4.1.22
        RC1 failed to install on 2 different servers with MySQL version 5.0.89
        I am attaching the configuration of the servers where RC1 failed and succeded as a zip file in case someone is interested.
        Can you describe the failures? The 1st is easy, PDO is disabled on that configuration. Revo simply will not support that; it requires PDO/PDO_mysql. The 2nd I have no clue why it would fail without more information; the configuration appears fine.
          • 12872
          • 68 Posts
          I tried installing again :
          At this stage - http://methodlabs.org/revo/setup/?action=install
          I get the following error - Fatal error: Class ’xPDOManager_’ not found in /home/metho14/public_html/revo/core/xpdo/xpdo.class.php on line 1152
            • 23510
            • 168 Posts
            I’m an Evolution guy...havent done any Revo installs yet. But I think if PDO is necessary for installation and is not on the server then Revo should detect it and report to the user that it is required and that installation can’t continue.
              • 32699 ☆ A M B ☆
              • 427 Posts
              Running MySQL 5.1.36-log here. And it is fine on that version.
                Get your copy of MODX Revolution Building the Web Your Way http://www.sanitypress.com/books/modx-revolution-building-the-web-your-way.html

                Check out my MODX || xPDO resources here: http://www.shawnwilkerson.com
                • 32699 ☆ A M B ☆
                • 427 Posts
                Quote from: indeman at Mar 23, 2010, 02:35 PM

                I tried installing again :
                At this stage - http://methodlabs.org/revo/setup/?action=install
                I get the following error - Fatal error: Class ’xPDOManager_’ not found in /home/metho14/public_html/revo/core/xpdo/xpdo.class.php on line 1152


                Make sure all of the files are uploaded. The class should be in the core/xpo/om.
                  Get your copy of MODX Revolution Building the Web Your Way http://www.sanitypress.com/books/modx-revolution-building-the-web-your-way.html

                  Check out my MODX || xPDO resources here: http://www.shawnwilkerson.com
                  • 12872
                  • 68 Posts
                  Quote from: wshawn at Mar 23, 2010, 08:41 PM

                  Quote from: indeman at Mar 23, 2010, 02:35 PM

                  I tried installing again :
                  At this stage - http://methodlabs.org/revo/setup/?action=install
                  I get the following error - Fatal error: Class ’xPDOManager_’ not found in /home/metho14/public_html/revo/core/xpdo/xpdo.class.php on line 1152
                  Make sure all of the files are uploaded. The class should be in the core/xpo/om.
                  In /core/xpdo/om/ I have the following files:
                  xpdogenerator.class.php
                  xpdomanager.class.php
                  xpdoobject.class.php
                  xpdoquery.class.php

                  The file xpdo.class.php exists in /core/xpdo/
                    • 28215
                    • 4,149 Posts
                    Are you running eAccelerator or APC? If so, disable them for the install.
                      shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                      • 12872
                      • 68 Posts
                      Quote from: splittingred at Mar 23, 2010, 11:22 PM

                      Are you running eAccelerator or APC? If so, disable them for the install.
                      I wouldn.t know how to check or disable if the host is running eAccelarator or APc. I have emailed their support with the question. They are running zend optimizer though.