We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19889
    • 616 Posts
    Hello
    MODx Rev has really been a frustrating experience for me so far - whenever I try to install it, I’m just not getting anywhere - please see me earlier posts.

    So I just downloaded the latest version from the SVN repository and gave it another go - installation went just fine - no errors - when trying to create/save a document, I’m not able to save the newly created document. Firefox shows me the following error: "syntax error () line 7 ext_all.js" - clearing the site cache results in an number of errors: a is null
    [Break on this error] Ext.DomHelper=function(){var s=null,j=...stopEvent();this.completeEdit()}}}}); - it just keeps going and going - firebug shows me a 100 errors - always the same so.

    Details: MODx Revolution 2.0.0-rc-1 rev6457, MAMP, SL

    by the way, this is something else, I’m always getting in the error console: "The ’charCode’ property of a keydown event should not be used. The value is meaningless."

    Login out and trying to login again doesn’t work either - I’m just getting a blank white page when calling the following page: http://localhost/cms/modxRev/manager/


    Hope somebody can help to finally get me going with MODx Revolution

    Thanks
      • 28215
      • 4,149 Posts
      Quote from: mmjaeger at Mar 08, 2010, 08:49 PM

      MODx Rev has really been a frustrating experience for me so far - whenever I try to install it, I’m just not getting anywhere - please see me earlier posts.

      So I just downloaded the latest version from the SVN repository and gave it another go - installation went just fine - no errors - when trying to create/save a document, I’m not able to save the newly created document. Firefox shows me the following error: "syntax error () line 7 ext_all.js" - clearing the site cache results in an number of errors: a is null
      [Break on this error] Ext.DomHelper=function(){var s=null,j=...stopEvent();this.completeEdit()}}}}); - it just keeps going and going - firebug shows me a 100 errors - always the same so.

      Details: MODx Revolution 2.0.0-rc-1 rev6457, MAMP, SL
      by the way, this is something else, I’m always getting in the error console: "The ’charCode’ property of a keydown event should not be used. The value is meaningless."
      Login out and trying to login again doesn’t work either - I’m just getting a blank white page when calling the following page: http://localhost/cms/modxRev/manager/

      1. First off, since you’re using SVN - did you run the build prior to install?
      2. What browser/OS are you using? Versions?
      3. What version of MAMP?
      4. What’s your PHP/MySQL versions? (client and server for MySQL)

      We’d love to help, but we’ll need that info before we can proceed.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 19889
        • 616 Posts
        Quote from: splittingred at Mar 08, 2010, 09:24 PM

        Quote from: mmjaeger at Mar 08, 2010, 08:49 PM

        MODx Rev has really been a frustrating experience for me so far - whenever I try to install it, I’m just not getting anywhere - please see me earlier posts.

        So I just downloaded the latest version from the SVN repository and gave it another go - installation went just fine - no errors - when trying to create/save a document, I’m not able to save the newly created document. Firefox shows me the following error: "syntax error () line 7 ext_all.js" - clearing the site cache results in an number of errors: a is null
        [Break on this error] Ext.DomHelper=function(){var s=null,j=...stopEvent();this.completeEdit()}}}}); - it just keeps going and going - firebug shows me a 100 errors - always the same so.

        Details: MODx Revolution 2.0.0-rc-1 rev6457, MAMP, SL
        by the way, this is something else, I’m always getting in the error console: "The ’charCode’ property of a keydown event should not be used. The value is meaningless."
        Login out and trying to login again doesn’t work either - I’m just getting a blank white page when calling the following page: http://localhost/cms/modxRev/manager/

        1. First off, since you’re using SVN - did you run the build prior to install?
        2. What browser/OS are you using? Versions?
        3. What version of MAMP?
        4. What’s your PHP/MySQL versions? (client and server for MySQL)

        We’d love to help, but we’ll need that info before we can proceed.

        Hello and thanks for replying - I did run the build before - no errors - everything run thru just fine:

        Apache version 2.0.63 (Unix)
        PHP version 5.2.11
        MySQL version 5.1.37

        I’m using Snow Leopard 10.6.2 with all the latest updates as well as the latest version of MAMP 1.8.4
          • 28215
          • 4,149 Posts
          Quote from: mmjaeger at Mar 08, 2010, 11:54 PM

          Hello and thanks for replying - I did run the build before - no errors - everything run thru just fine:

          Apache version 2.0.63 (Unix)
          PHP version 5.2.11
          MySQL version 5.1.37
          I’m using Snow Leopard 10.6.2 with all the latest updates as well as the latest version of MAMP 1.8.4
          Still need these answered, plus:

          1. What browser/OS are you using? Versions?
          2. What’s your PHP/MySQL versions? (client and server for MySQL)
          3. Are you running APC or eAccelerator?
          4. Are there any relevant errors in core/cache/logs/error.log or install logs in core/cache/logs/ (usually timestamped)?

          Plus, dont run Firebug while running JS apps. Never a good idea.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 19889
            • 616 Posts
            eAccelerator and Zend Optimizer are running:

            Apache version 2.0.63 (Unix)
            PHP version 5.2.11
            MySQL version 5.1.37

            I’m using Snow Leopard 10.6.2 with all the latest updates as well as the latest version of MAMP 1.8.4
            Firefox 3.6
            there is no core/cache/logs/ folder
              • 28215
              • 4,149 Posts
              Quote from: mmjaeger at Mar 09, 2010, 08:14 AM

              eAccelerator and Zend Optimizer are running:

              Apache version 2.0.63 (Unix)
              PHP version 5.2.11
              MySQL version 5.1.37

              I’m using Snow Leopard 10.6.2 with all the latest updates as well as the latest version of MAMP 1.8.4
              Firefox 3.6
              there is no core/cache/logs/ folder

              Turn eAccelerator off and re-run setup: http://svn.modxcms.com/docs/display/revolution/Troubleshooting+Installation

              I cant verify that Zend Optimizer wont cause problems either, but I dont think it will.

              Make sure core/cache is writable by your webserver.
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: splittingred at Mar 09, 2010, 08:34 AM

                Turn eAccelerator off and re-run setup: http://svn.modxcms.com/docs/display/revolution/Troubleshooting+Installation

                I cant verify that Zend Optimizer wont cause problems either, but I dont think it will.
                eAccelerator should work now in the latest RC-1 revisions; Zend Optimizer definitely is not a problem.