Hello all
Upgrading from Evolution so did "Upgrade existing install" - trying to install Revolution:
Language: en
1) Connecting to mysql server: Success!
Connection character set: utf8
2) Checking database:Success!
3) Click next and get:
"Warning: PDO::exec() [pdo.exec]: SQLSTATE[42000]: Syntax error or access violation: 1253 COLLATION ’latin1_swedish_ci’ is not valid for CHARACTER SET ’utf8’ in /web2/user23094/website/core/xpdo/om/mysql/connect.inc.php on line 12
Warning: Cannot modify header information - headers already sent by (output started at /web2/user23094/website/core/xpdo/om/mysql/connect.inc.php:12) in /web2/user23094/website/setup/includes/modinstallrequest.class.php on line 98"
Where does the latin swedish stuff come from?
So tried "New Installation"
And got same error except it was "1253 COLLATION ’hp8_english_ci’ is not valid for CHARACTER SET ’utf8’....."
’hp8_english_ci’ was the setting I put in that time.
Any ideas please?
Thanks.
The latin_swedish collation is the default character set in almost all MySQL installations (don’t ask).
Be careful what you do next. It’s easy to make things worse.
I’ll leave the advice to those who know more about character sets than I do.
Despite your warning I have gone further (foolishly?)
I put in Latin1 instead of utf8 and it liked it.
But then on clicking to install it spat out:
"Warning: include(/web2/user23094/website/setup/includes/tables_migrate.php) [function.include]: failed to open stream: No such file or directory in /web2/user23094/website/setup/includes/modinstall.class.php on line 286
Warning: include() [function.include]: Failed opening ’/web2/user23094/website/setup/includes/tables_migrate.php’ for inclusion (include_path=’.:’) in /web2/user23094/website/setup/includes/modinstall.class.php on line 286
Catchable fatal error: Argument 1 passed to modInstall::writeConfig() must be an array, boolean given, called in /web2/user23094/website/setup/includes/modinstall.class.php on line 300 and defined in /web2/user23094/website/setup/includes/modinstall.class.php on line 523"
The reason is that there is no tables_migrate.php in the includes folder.... hmmm...
ah, it’s got a note on it "to do".
-
MODX Staff
- 12,272 Posts
You can’t currently upgrade from Evo to Revo.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
Quote from: rthrash at Feb 26, 2010, 05:35 PM
You can’t currently upgrade from Evo to Revo.
Well, you can, but not by installing one on top of the other. It’s pretty much a manual process involving a lot of cutting and pasting and rewriting tags.
Sorry, I should have noticed what you were trying to do.
See this page for more information:
http://bobsguides.com/migrating-revolution.html
Thanks everyone
I’ve gone for Bob’s "latin_swedish collation" with a new install and I’m up and running.
Glad you got it sorted.