We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 24073
    • 7 Posts
    I’m having trouble getting the latest general beta installed.

    I’m running wamp on a
    Windows Vista Business local machine,
    php 5.2.9 (I can’t go to 5.3 because of other incompatible systems)
    MySQL 5.1.36

    If I try to install R2.0.0 I get the 5.0.51a incompatible error next to the MySQL CLIENT check. (Is the Client important to R2??)

    So, I installed this...

    http://www.apachelounge.com/viewtopic.php?p=13207

    ...which got rid of the "Your PHP MySQL library version 5.0.51a differs from your MySQL server version" error message in MySQLAdmin.

    But, now the R2 install causes apache to crash when I try to check the connectivity to the database. (All other systems seem to be working? Including my Modx Evolution installation)

    Can someone point me in the right direction to get this working?

    TIA
      • 8609
      • 607 Posts
      Quote from: PurpleEdge2010 at Jan 04, 2010, 06:36 AM

      I’m having trouble getting the latest general beta installed.

      I’m running wamp on a
      Windows Vista Business local machine,
      php 5.2.9 (I can’t go to 5.3 because of other incompatible systems)
      MySQL 5.1.36

      If I try to install R2.0.0 I get the 5.0.51a incompatible error next to the MySQL CLIENT check. (Is the Client important to R2??)

      So, I installed this...

      http://www.apachelounge.com/viewtopic.php?p=13207

      ...which got rid of the "Your PHP MySQL library version 5.0.51a differs from your MySQL server version" error message in MySQLAdmin.

      But, now the R2 install causes apache to crash when I try to check the connectivity to the database. (All other systems seem to be working? Including my Modx Evolution installation)

      Can someone point me in the right direction to get this working?

      TIA

      I resolved this problem on Wampserver by installing the PHP 5.3 addon, and then switching to PHP 5.3 when installing and running Revo. Then you can switch back to 5.2.11 when running your other programs. This is one of the things i like about wampserver, the ability to run different versions of stuff. Works fine for me. See my post about it: http://codingpad.maryspad.com/2010/01/11/modx-revolution-and-wamp/

      Hope this helps.
        • 24073
        • 7 Posts
        Thank very much Mary - it never occurred to me to try that!

        I’ve decided to stick to Evolution for now and I am slowly getting up to speed by following your excellent tutorials. I haven’t tried to install Revolution on my live server yet, but I suspect I will have similar difficulties, so I think I am better sticking with Evo ’til I am a bit more experienced with ModX - Either way, I have a lot to learn!
          • 8609
          • 607 Posts
          Quote from: PurpleEdge2010 at Jan 11, 2010, 07:34 PM

          Thank very much Mary - it never occurred to me to try that!

          I’ve decided to stick to Evolution for now and I am slowly getting up to speed by following your excellent tutorials. I haven’t tried to install Revolution on my live server yet, but I suspect I will have similar difficulties, so I think I am better sticking with Evo ’til I am a bit more experienced with ModX - Either way, I have a lot to learn!

          No problem!! Don’t know how your live server is configured, but I was able to install Revo Beta 5 on Hostgator with no worries smiley