We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 23453
    • 5 Posts
    Hello,

    I tried to install Revolution on OS X, but ran into this problem:
    Fatal error: Class 'xPDO' not found in /Volumes/Web/ZOK/htdocs/core/xpdo/xpdo.class.php on line 539


    I have PDO enabled (mysql driver works fine), memory_limit is 128Mb, execution time is 120, I am running MAMP Pro, MySQL version is 5.1.37

    Any suggestions?
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      xPDO is an extension of PDO, it doesn’t come with PHP or MAMP and has to be installed and included like any other library. Since it’s included as part of Revolution, something must be wrong with the Revo installation.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 28215
        • 4,149 Posts
        Quote from: pit at Jan 03, 2010, 09:14 AM

        I have PDO enabled (mysql driver works fine), memory_limit is 128Mb, execution time is 120, I am running MAMP Pro, MySQL version is 5.1.37
        1. Whats your PHP version?
        2. Can you verify that the file is actually there? And that there’s a xPDO class defined in it?
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 10221
          • 5 Posts
          I’m having the same problem on CentOS 5.3. Getting the same error as pit.

          PDO is enabled and mysql working fine, memory_limit is 48Mb, execution time is 60. Running Apache 2.2.3 with PHP 5.2.11, MySQL 5.0.86. MySQL extension: mysqli. The file exists and the class is there. Wonder why it doesn’t find it..

          Any ideas?
            • 28215
            • 4,149 Posts
            1. Are you running eAccelerator?
            2. Is this the traditional or advanced distribution?
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 10221
              • 5 Posts
              Quote from: splittingred at Jan 15, 2010, 11:19 AM

              1. Are you running eAccelerator?
              2. Is this the traditional or advanced distribution?

              1. No.
              2. It’s the traditional one.


              EDIT:

              Thank you for mentioning eAccelerator, Shaun. It just got me thinking.. APC is another caching system, and that I do have. It didn’t occur to me before. I just disabled it and the error is gone.

              Seems like Revolution doesn’t like caching systems... Pity...
                • 22303 MODX Staff
                • 10,725 Posts
                Quote from: frostshifter at Jan 15, 2010, 11:38 AM

                Quote from: splittingred at Jan 15, 2010, 11:19 AM

                1. Are you running eAccelerator?
                2. Is this the traditional or advanced distribution?

                1. No.
                2. It’s the traditional one.


                EDIT:

                Thank you for mentioning eAccelerator, Shaun. It just got me thinking.. APC is another caching system, and that I do have. It didn’t occur to me before. I just disabled it and the error is gone.

                Seems like Revolution doesn’t like caching systems... Pity...
                These are the result of errors with the caching systems TBH.
                  • 20364
                  • 89 Posts
                  I tried to hit my website today and got the same thing:

                  Fatal error: Class ’xPDO’ not found in /home/lfgsm1/public_html/core/xpdo/xpdo.class.php on line 539

                  It was working fine on Friday and has not been touched since. Very confused.

                  EDIT:

                  This was solved by changing the PHP version on my server from 5.3.1 to 5.2.12. Is it safe to assume MODx isn’t compatible with 5.3.1?
                    • 22303 MODX Staff
                    • 10,725 Posts
                    Quote from: mr.johnny at Jan 25, 2010, 08:25 AM

                    This was solved by changing the PHP version on my server from 5.3.1 to 5.2.12. Is it safe to assume MODx isn’t compatible with 5.3.1?
                    It’s perfectly compatible with PHP 5.3.1; it’s what I’m developing on. This issue is caused by APC and eAccelerator bugs with 5.3.x, though our most recent development branch is now confirmed working with APC running in 5.3.1 (i.e. we worked around the APC bug to avoid it).
                      • 22303 MODX Staff
                      • 10,725 Posts
                      FWIW, the issue with opcode caching systems like APC, eAccelerator, and WinCache is resolved for the upcoming 2.0.5 release.