We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 20473
    • 15 Posts
    Hi

    I have updated to b5 and it seemed like a successful install however now I cannot log in to the manager section
    I do not get an error message but keep staying at the log in page

    I had a site working with b3.
    I then did a svn upgrade while I was still logged in to the management console.
    After this I went to the setup screen
    I saw the note that manager’s should all be logged out, so i tried to go back to the manager screen however now got errors, but presumed it was just because of the svn upgrade
    I returned back to setup and performed the upgrade.

    I have checked the blockeduntil fields, changed password etc. I also notice there was a value in the sessionid field of the user_attributes table. I deleted that hoping it might help but no luck.

    Is there anything else I could try?

    Thanks
    Mark
      • 20473
      • 15 Posts
      Deleting the database and performing a clean install (with different admin username in case cache issues) also did not work so I will keep looking into this.

      One thing I noticed is that I got the ’could not detect mysql version’ messaged raised in another thread but I presume this would not cause any problems
        • 17499 ☆ A M B ☆
        • 872 Posts
        I too have the mysql version error message!

        It is due to the following line (79) in setup/includes/modinstalltest.class.php :

        <?php
        $mysqlVersion = @mysql_get_server_info();
        


        This an odd error, can you point me to the other thread who talk about it? If it’s an issue encountered by others it should on Jira.

          • 20473
          • 15 Posts
            • 20473
            • 15 Posts
            I don’t know if this is related to not being able to log in however in firebug I can see the following js file is trying to be retrieved and is not found:

            \modx\manager\assets\modext\core\modx.msg.js

            Just so it is clear I am still getting the appropriate message if I enter an incorrect password so it is obviously recognizing the correct one.

              • 28215
              • 4,149 Posts
              1. If you’re using SVN, you need to be making sure to run the core build when it says [REBUILD/UPGRADE REQUIRED] (which it has a few times recently). See the notes here:

              http://svn.modxcms.com/docs/display/revolution/Development+and+Testing+Notes

              2. the MySQL check error only occurs if your MySQL connection is incorrectly setup; however, even if the error occurs, you should still be able to proceed.

              3. As stated in this sticky thread near the top of the forums titled "BEFORE YOU POST READ THIS:"


              If you’re posting about a bug, please state all of your Environment information in your post: Server OS, Server Version, PHP Version, MySQL Version, is pdo_mysql installed, your Browser type and version, and any other environment data we should know.

              That includes your MySQL client and server version.

              4. I’ve added a connect statement in r6184 to assist with the mysql_get_server_info call. Let me know if that fixes it.
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 17499 ☆ A M B ☆
                • 872 Posts
                The connect statement fixed the issue for me.
                  • 20473
                  • 15 Posts
                  Ditto re the connect statement.
                  Also I think the log in error was because I had not correctly done the build

                  Thanks for your help