We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 1778
    • 659 Posts
    Hi all,
    And thanks again for the fantastic job done with revolution.

    I tried to install the last svn version from SVN bleeding edge, and cannot pass the second step of installation!
    On the screen connection information, once filled all fields "test database connection and view collation" gives the message : Connecting to mysql server: Success! (all seems ok uh?)
    then
    "Create or test selection of your database" says "Checking database:Could not connect to the mysql server."

    In my apache2/error.log I have this message :

    Warning: PDO::__construct() [pdo.--construct]: [2002] Argument invalide (trying to connect via unix://) in /var/www/2.0/core/xpdo/xpdo.connect.inc.php on line 288 referer http://mysite.fr/setup/?action=database.

    When I install last Beta4 from SVN stable all works fine... Any idea of what to do to have B5 working ?
    Thanks

    Debian 5 (lenny)
    Apache 2.2
    PHP 5.3
    Mysql 5.1
      • 28215
      • 4,149 Posts
      Not sure; definitely a misconfiguration, but my guess is that it sounds like your collations or charset is not set right.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 1778
        • 659 Posts
        all seems right in my config...
        If I install the beta4 from SVN stable, following exactly the same steps and using the same parameters for dbname, user, collation etc etc, all works fine with version from svn stable.
        The problem is only with the svn version from bleeding-edge branche... It’s why I don’t understand what’s wrong with b5...
          • 28215
          • 4,149 Posts
          - Whats your mysql client and server version (full versions, please)?
          - Whats the charset for your MODx database?
          - What collation are you specifying?
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 1778
            • 659 Posts
            I attach my phpinfo if it can help...

            But what is this major difference between B4 and B5 which make the install of B5 is not possible but B4 is fine ?

            Collation : UTF8_general_ci
            Character-set for the database (and all databases on my server) UTF8 too...

            Once again all is fine with files from SVN stable (http://svn.modxcms.com/svn/tattoo/tattoo/branches/revolution/), the problem appears just when trying with files from bleeding-edge (http://svn.modxcms.com/svn/tattoo/tattoo/branches/2.0/)

            Thanks for your help
              • 28215
              • 4,149 Posts
              Seems the culprit is that you’re using mysqlnd, which is still in development and untested; not to mention its PDO drivers have known bugs and are problematic.
              mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $
              
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 28215
                • 4,149 Posts
                Also:

                Warning: PDO::__construct() [pdo.--construct]: [2002] Argument invalide (trying to connect via unix://) in /var/www/2.0/core/xpdo/xpdo.connect.inc.php on line 288 referer http://mysite.fr/setup/?action=database.


                There is no line 288 for xpdo.connect.inc.php, which tells me that something’s misconfigured on your mysql or pdo setup.
                  shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                  • 28215
                  • 4,149 Posts
                  Is your mysql socket setup correctly? This is an error message you’d see if that was an issue.
                    shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                    • 1778
                    • 659 Posts
                    No error in mysql.log...

                    BTW, MysqlInd is the native driver for PHP5.3... I’m sure I’m not alone using it, but sure it is not perfect !!

                    And once again, it works fine with installing revolution from svn stable...

                    Is there a way to "upgrade" my svn version B4 (from svn stable) with the B5 from svn bleeding edge branch?
                    Or replace/use the build.config.php from B4 in B5 ?
                      • 1778
                      • 659 Posts
                      OOOOps !

                      I made a mistake in the error message ! sorry ! the exact message is :

                      PDO::__construct(): [2002] Invalid argument (trying to connect via unix://) in /var/www/2.0/core/xpdo/xpdo.class.php on line 288, referer: http://www.mysite.fr/setup/?action=database ...